0.9 Upgrade command failed


  • GNU/Linux Admin

    @pichalite said:

    I believe you have to update to latest on 0.8.x before upgrading to 0.9

    Yes, this is correct (although right now all of the upgrade scripts are still there, so this is a good reminder for me to remove them, thanks!).


  • Community Rep

    Ah sorry, the probably....

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.9.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log



  • @julian said:

    we could have a pre-release channel that upgrades a week before a new milestone launches, so some users can test it out and report back

    I'd be happy to do this. I already run master locally, and upgrade X.X.X locally before doing anything on my production site.

    How would you let us know something is ready for testing?


  • GNU/Linux Admin

    We develop on master, so if you run master you wouldn't experience the issues we'd have as well.

    Ideally it would be a site administrator who runs on stable, but when requested, will duplicate his db, and run the upgrade from, for example, v0.8.2 to v0.9.0


  • FreeBSD/OpenBSD

    @julian said:

    Ideally it would be a site administrator who runs on stable, but when requested, will duplicate his db, and run the upgrade from, for example, v0.8.2 to v0.9.0

    I would not mind doing that. Actually, I already do that. It is part of my upgrade process before upgrading the real forum. I am sure I am not the only one. I am late for the 0.9.0 but I would be OK to give it a try for the next release.



  • @scottalanmiller said:

    Ah sorry, the probably....

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.9.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log

    Sorry for the newb post.....

    I've tried to upgrade 3 times now each time breaking my install. Is the above the way to go????

    Trying to upgrade from v0.7.1-dev to v0.9.0.

    Please help?



    1. Bringing base dependencies up to date... OK

    2. Updating NodeBB data store schema.
      10/11 12:39 [15868] - info: Beginning database schema update
      10/11 12:39 [15868] - error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
      10/11 12:39 [15868] - error: [upgrade] Please ensure that you did not skip any minor version upgrades.
      10/11 12:39 [15868] - error: [upgrade] (e.g. v0.1.x directly to v0.3.x)
      OK

                           NodeBB Upgrade Complete!

  • Community Rep

    @Phate said:

    @scottalanmiller said:

    Ah sorry, the probably....

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.9.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log

    Sorry for the newb post.....

    I've tried to upgrade 3 times now each time breaking my install. Is the above the way to go????

    Trying to upgrade from v0.7.1-dev to v0.9.0.

    Please help?

    You need to go through the 0.8.x series first.


  • Community Rep

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.8.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log

    Make sure that things are okay then...

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.9.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log


  • Plugin & Theme Dev

    @scottalanmiller said:

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.8.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log

    Make sure that things are okay then...

    git fetch; git pull, npm i; ./nodebb upgrade; git checkout v0.9.x; git pull; npm install; ./nodebb stop; ./nodebb upgrade; ./nodebb start; ./nodebb log

    So easy lol


  • Community Rep

    @julian said:

    @Kowlin Possibly... I made the mistake of using peer dependencies awhile back, and it's been nothing short of a headache. The idea in and of itself is fantastic, but the implementation was not suitable for a project like ours.

    So are we doing away with peer dependencies?


  • GNU/Linux Admin

    Depends, why do you need them in your plugin?


  • Community Rep

    No I don't need them, but curious since they're causing trouble


  • GNU/Linux Admin

    The way npm handles peer dependencies left much to be desired, especially in a development landscape like ours where versions go up regularly and different rates compared to plugins.

    Specifically, if a module A required a peer dependency B with a fairly strict version (e.g. ~0.15.0), then if that dependency got updated to v0.16.0 or above, then any future attempts to install module A would throw a peer dependency error and abort the npm installation, leaving NodeBB in a state that would not run. That's not so good for non-developers 😄


Log in to reply
 

Suggested Topics

  • 13
  • 2
  • 13
  • 6
  • 31
| |