Need help about Install

Technical Support

Suggested Topics

  • ubuntu installed MongoDB error

    Solved Technical Support
    0 Votes
    12 Posts

    @phenomlab I reinstalled and deleted it. I think it installed successfully this time.

  • NodeBB on Oracle VPS [I need help!]

    Unsolved Technical Support
    0 Votes
    4 Posts

    Your issues with firewall are likely because Oracle is, essentially, using firewalld rules for all their images, even ones that don't have it included. So if you are running on Ubuntu, and trying to use ufw like most tutorials will recommend you do, it will do nothing with the default iptables entires and be essentially useless. And the bigger problem is that some of their rules are required to start to VMs (they need iSCSI access rules on boot)

    The easy solution is to just give in to Oracle's config and install firewalld:

    sudo apt install firewalld sudo systmctl enable --now firewalld

    (And ensure ufw is disabled)

    You can then manage rules using firewall-cmd. For example:

    sudo firewall-cmd --permanent --add-service={http,https} sudo firewall-cmd --reload

    Will allow http/https traffic.

    The second option is the one I assume you tried: fix iptables and use ufw. But this is a bit more complex than it seems.
    First issue is that IIRC the iptables rules will be applied again on reboot. Now, cloud init can be disabled, but there is another issue - the iSCSI rules.
    The official Oracle workaround for ufw potentially making the VMs unbootable is "don't use ufw" (, and while you should be able to just ensure everything is correctly configured with ufw, I honestly stopped bothering. firewalld works fine for me, so, like Oracle, I would recommend that route instead.

    Additionally there is separate OCI networking and their firewall. You have to remember that Network Security Groups override Security Lists, so if you have one assigned to your VNIC, you need to edit it instead of the subnet-wide SL.

    If there is something else specifically you need help with you'll need to give more details - this post is just based on a guess you have the common issues.

  • 0 Votes
    9 Posts

    ☠ ☠ ☠ Check the credit card!!! ☠ ☠ ☠


  • 1 Votes
    3 Posts

    Pulling from Master helped. However the webpage that starts NodeBB after setting up the DB through the webpage, doesn't restart it now. I had to kill the command line, and manually start nodeBB. But then it works fine. Just an FYI.

  • 0 Votes
    8 Posts

    I have the same problem on running upgrade
    #npm version
    nodebb: '0.6.1',
    npm: '2.5.1',
    http_parser: '2.3',
    modules: '14',
    node: '0.12.1',
    openssl: '1.0.1m',
    uv: '1.0.2',
    v8: '3.28.73',
    zlib: '1.2.8'