Admin Panel Broken


  • GNU/Linux Admin

    That's a little odd, it doesn't sound like you're running a regular VPS then, if you can't control the port? What service are you using?



  • @julian I am nodebb running on aws with nginx


  • Global Moderator

    Here's the example config from our docs:

    server {
        listen 80;
    
        server_name forum.example.org;
    
        location / {
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
    
            proxy_pass http://127.0.0.1:4567;
            proxy_redirect off;
    
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
        }
    }
    

    Here's yours:

    server {
    
      listen 443;
      ssl on;
      ssl_certificate /etc/nginx/ssl/cert_chain.crt;        
      ssl_certificate_key /etc/nginx/ssl/private.key;    
      server_name myurl.com;
    
      location / {
    
        proxy_pass       http://127.0.0.1:8080;
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Host $server_name;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;
    
        proxy_redirect off;
    
        # Socket.IO Support
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    
      }
    
      gzip on;
      gzip_vary on;
      gzip_min_length 10240;
      # gzip_proxied expired no-cache no-store private auth;
      gzip_types text/plain text/css text/xml text/javascript application/x-javascript application/xml;
      gzip_disable "MSIE [1-6]\.";
    
    }
    

    Firs of all, I'd try to get your forum working with the minimum amount of stuff. Try disabling SSL and gzip and all of the other extraneous stuff there, and ensure that all of the proxy operations are typed correctly and in the same order as the example config.

    Please also share any errors you encounter client-side or server-side when running or building nodebb. Remove the port section from your config.json since you obviously aren't using it.

    Make sure you are neither installing nor running nodebb with root privileges.



  • @PitaJ The problem is that I am not able to view the site since Google prohibits user visiting site without https. Thanks for the suggestion, I'll delete the gzip and see how it goes. What makes it harder to debug is that the log doesn't show up any error.


  • Global Moderator

    @Kinchtwck Google absolutely does not do that, what are you talking about? Try a different browser or something.


  • Community Rep

    @Kinchtwck said in Admin Panel Broken:

    @scottalanmiller the nodebb is running on 8080. For reason I don' know, the nodebb always runs on port 8080 despite the setting in config.json.

    If you are still working on getting NodeBB to run on the correct port as specified by the config file, why do you have the file set to three ports? Start with just getting one working, as only one is working anyway.


  • Community Rep

    @julian said in Admin Panel Broken:

    That's a little odd, it doesn't sound like you're running a regular VPS then, if you can't control the port? What service are you using?

    VPS by definition couldn't cause that problem. A VPS you'd always be able to control the port.


  • Community Rep

    @Kinchtwck said in Admin Panel Broken:

    What makes it harder to debug is that the log doesn't show up any error.

    What does netstat -tulpn tell us when you clean up the ports list and restart NodeBB?


  • GNU/Linux Admin

    @scottalanmiller Yes indeed, that's why I said it doesn't sound like it was a VPS 😄

    Sadly we're fairly limited in terms of AWS experience, so I can't really help there...


  • Community Rep

    @julian said in Admin Panel Broken:

    Sadly we're fairly limited in terms of AWS experience, so I can't really help there...

    Nothing to know there. AWS is "just a server" like any other. That AWS does the hosting doesn't change things at the OS level. It's the same as a physical server.



  • @PitaJ I tried only initiate without SSL but the result was the same



  • @scottalanmiller So previously, before updating, I ran the nodebb on 4567, 4568,4569 and pass the 443 proxy to these 3 with Nginx. Now, despite the config.json, I have to forward to 8080 which is the port that the NodeBB is on. I might try to initiate another AWS instance with the same setting to see how it goes.

    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      3215/nginx      
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      2944/node       
    tcp        0      0 127.0.0.1:21            0.0.0.0:*               LISTEN      608/vsftpd      
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      928/sshd        
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1111/sendmail: MTA:
    tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      3215/nginx      
    tcp        0      0 0.0.0.0:27017           0.0.0.0:*               LISTEN      1294/mongod     
    tcp        0      0 127.0.0.1:587           0.0.0.0:*               LISTEN      1111/sendmail: MTA:
    tcp6       0      0 :::22                   :::*                    LISTEN      928/sshd        
    tcp6       0      0 :::9000                 :::*                    LISTEN      1049/hhvm       
    udp        0      0 0.0.0.0:42932           0.0.0.0:*                           544/dhclient    
    udp        0      0 0.0.0.0:68              0.0.0.0:*                           544/dhclient    
    udp6       0      0 :::59961                :::*                                544/dhclient

  • Community Rep

    @Kinchtwck that is SO weird, because that's not a default, and doesn't appear in your config. Maybe do a ...

    grep 8080 -R *


  • @scottalanmiller Thanks, I figured out the issue with the dashboard. In the error.log of nginx, it shows that

      /var/lib/nginx/proxy/8/83/0000000838" failed (13: Permission denied) while reading upstream
    

    Even though the permission to this folder is valid, I am still not able to read the file. I have to rename the folder and restart the nginx according to Permission denied while reading upstream. But the port issue remains unresolved.


  • Community Rep

    @Kinchtwck said in Admin Panel Broken:

    Even though the permission to this folder is valid, I am still not able to read the file. I have to rename the folder and restart the nginx according to Permission denied while reading upstream. But the port issue remains unresolved.

    What OS are you on? Perhaps SELinux is an issue for you?



  • @scottalanmiller I am on Ubuntu 16.04. Not sure if that's an issue though but I haven't encountered any reading issue until this update.


  • Community Rep

    @Kinchtwck said in Admin Panel Broken:

    @scottalanmiller I am on Ubuntu 16.04. Not sure if that's an issue though but I haven't encountered any reading issue until this update.

    No SELinux on Ubuntu so can't be the issue unless you added it manually 🙂


  • Community Rep

    @scottalanmiller said in Admin Panel Broken:

    @Kinchtwck that is SO weird, because that's not a default, and doesn't appear in your config. Maybe do a ...

    grep 8080 -R *
    

    Back to this... any output?



  • @scottalanmiller Below is the final output from the command

    nodebb/node_modules/safe-buffer/README.md:server.listen(8080)
    nodebb/node_modules/body/README.md:http.createServer(app).listen(8080)
    nodebb/node_modules/body/README.md:}).listen(8080)
    nodebb/node_modules/body/README.md:}).listen(8080)
    nodebb/node_modules/body/README.md:}).listen(8080)
    nodebb/node_modules/body/README.md:}).listen(8080)
    nodebb/node_modules/secure-keys/package.json:  "_shasum": "f0c82d98a3b139a8776a8808050b824431087fca",
    nodebb/node_modules/async-listener/test/core-asynclistener-nexttick-remove.simple.js:server.listen(8080, function() {
    nodebb/node_modules/async-listener/test/core-asynclistener-only-add.simple.js:server.listen(8080, function() {
    nodebb/node_modules/jimp/server.js:app.listen(8080);
    nodebb/node_modules/jimp/server.js:console.log("Serving on http://127.0.0.1:8080");

  • GNU/Linux Admin

    Yeah, that's not NodeBB, looks like you're launching jimp, the image manipulation tool... 😕


Log in to reply
 

Suggested Topics

| |