UREGENT PROBLEM



  • Hello,

    I cannot any more start my nodeBB Application. I get this error :

    Can someone please tell me what to do !
    Thanks !

    0_1480531833503_Capture d’écran 2016-11-30 à 19.48.20.png


  • Plugin & Theme Dev

    maybe you have another nodebb stuck or runing

    type

    ps aux | grep node

    and kill all stuf running
    kill -9 pid

    then run your node again



  • @exodo
    I cannot understund why I cannot kill the process. Can you help me please !

    root@HOPINK:~/nodebb# ps aux | grep node
    root 1388 0.0 0.1 11740 936 pts/0 S+ 14:25 0:00 grep --color=auto node
    root@HOPINK:~/nodebb# kill -9 1388
    bash: kill: (1388) - No such process
    root@HOPINK:~/nodebb#


  • Plugin & Theme Dev

    @kacemlight said in UREGENT PROBLEM:

    @exodo
    I cannot understund why I cannot kill the process. Can you help me please !

    root@HOPINK:~/nodebb# ps aux | grep node
    root 1388 0.0 0.1 11740 936 pts/0 S+ 14:25 0:00 grep --color=auto node
    root@HOPINK:~/nodebb# kill -9 1388
    bash: kill: (1388) - No such process
    root@HOPINK:~/nodebb#

    you dont have any process to kill there
    try stop your mongo and start it again then



  • @exodo
    Thank you !

    Can you tell me how please ? I cannot start it.



  • Is nodebb died ? Can someone tell me what to do ? I'm losing a thousands of users !


  • Gamers

    There seems to be a problem with your Mongo settings. Another possibility may be that the mongo server is not running. This could have a number of reasons.

    Can you check the following:

    • Is MongoDB running?
    • Can you access the mongodb port on the IP/hostname that you use to connect it to?
    • Are your mongo login errors

    If you can't find a solution using these questions, can you tell me your setup? For instance, do you run MongoDB locally or do you use a hosted service?



  • @kacemlight said in UREGENT PROBLEM:

    Is nodebb died ? Can someone tell me what to do ? I'm losing a thousands of users !

    If you are claiming this kind of critical loss, then you should pay for a supported version and not cheap out and do things you do not understand.

    FOSS != us required to do anything for you for free.


  • Admin

    As others have said, your MongoDB server is down. Start it up again.

    Use Google to learn more about how to use MongoDB. We cannot teach you that in depth knowledge here.



  • @julian I already tried this :
    root@HOPINK:~# mongod
    2016-11-30T16:28:23.709-0500 I STORAGE [initandlisten] exception in initAndListen: 29 Data directory /data/db not found., terminating
    2016-11-30T16:28:23.709-0500 I CONTROL [initandlisten] dbexit: rc: 100
    root@HOPINK:~#

    I'm using nodebb more than 2 years. Before I had issues with redis and I rebuilt my forum one year ago to use Mongodb. It was stable untill today, I connot any more restart it.
    I just need your expertise. You can search my name and see my very old discussion here.


  • Admin

    @kacemlight You've just sent me your server root password. This is a terrible idea and a security risk. Change your passwords immediately.

    I do not resolve installation issues for free. It is a liability as it opens me and the company up to potential legal issues.

    Please see if someone here is willing to help you. There will be a cost associated with it, as is the case with all server administration work.



  • @julian Ok. How can I pay you to resolve this problem ?


  • Admin

    Anyone can, actually. If anybody here wants to help @kacemlight out, please DM him with your bid.



  • @julian said in UREGENT PROBLEM:

    Anyone can, actually. If anybody here wants to help @kacemlight out, please DM him with your bid.

    A failed Mongo instance and that post says the db file is missing. My money is on no backups either. Not wasting my time even thinking about it anymore. Good luck to anyone that attempts something here.



  • Looks like you have not been keeping your system up to date. That's an ancient version of NodeBB.

    Your database says that its data is missing. Not much we can do there. Do you have backups? What happened when the site went down? Have you rebooted? Tons of the issues you've had here (not including the missing data) would have been fixed in a split second with a quick reboot.


  • GNU/Linux

    Probably the files are not lost at all - I don't know whether mongod uses a default configuration file or just default configuration if nothing is specified via --config.
    Maybe your system uses systemd which means you're supposed to start mongodb with systemctl start mongodb, replace start with restart, stop or status for respective actions.

    And if it's not systemd you're using, it might be any other init system with similar structure, in that case we'd need to know more about the system. uname -a would be a start.


  • Admin

    @frissdiegurke Yeah we can only speculate at this point but my guess is he's not on Xenial which means he's on upstart, not systemd.

    Does Xenial even load a proper systemd config for mongo anyway?



  • This post is deleted!


  • Good point, what OS is this even on? And did you try rebooting like I said?


  • Community Rep

    Does Xenial even load a proper systemd config for mongo anyway?

    Nope.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.