Installing on ubuntu 14.04 - impossible?

  • I've ran through 2 or 3 guides for installing NodeBB on Ubuntu 14.04 with MongoDB, and am unable to install NodeBB and get it to run successfully. Is there a recent, up to date, reliable guide on how to install this software on Ubuntu 14.04?

    It seems that nodebb doesn't have its dependencies correctly set. Is there is a specific version of NodeBB that will actually install smoothly for 14.04?

    some errors:
    (runs, but throws errors)
    1 Error: Cannot find module 'colors'
    2 Error: Cannot find module '../build/Release/lwip_image'

    (cannot even run setup)
    Could not start: MODULE_NOT_FOUND

  • Plugin & Theme Dev

    @keyes9 did you run npm install --production?

  • Yes. It doesn't seem to be installing all of the dependencies for both 0.8.x and 1.x.x. 0.8.x encounters run-time packages that are missing and 1.x.x can't even run the setup script. This could definitely be an NPM issue, but I was hoping to get an answer on which packages are 100% confirmed to work. The official documentation implies the latest of everything which seems to be making it impossible for me to install successfully.

  • Community Rep

    some errors:
    (runs, but throws errors)

    Wait, what? why did you start with the 0.8.x branch?

    Delete the node_modules folder, switch to the v1.x.x branch, and try npm install --production again. Sometimes npm does some funny things so it's easier to just blow the whole thing away.

  • @Bri

    I tried both. I cannot run nodebb or run the setup with 1.x.x. I have installed for production. Is this more of an NPM question? I'm guessing it has to do with my nodejs/npm setup. Doesn't seem to be installing packages correctly for nodebb.

    :~/nodebb$ npm start
    node loader.js
    throw err;
    Error: Cannot find module 'nconf'

    It seems like my NPM install is failing silently; node_modules is empty each time I try. This has absolutely nothing to do with NodeBB. my apologies for wasting your time. Please close or delete.

  • Community Rep

    I've seen something like this before when trying to install on a DO droplet that had 512KB of RAM. What are the specs of the machine you're installing on?

  • Gamers

    @Bri That´s correct. Nodebb need 1GB minimum. Try several times in a 512MB Droplet. Don´t work.

    Also, Just installed two days ago, follow this instructions (I made a manual and it works for me):


    curl -sL | sudo -E bash -
    sudo apt-get install -y git nodejs mongodb build-essential
    apt-get install git build-essential imagemagick
    git clone -b v1.x.x nodebb

    **Need some update before installation:

    PUG: npm install pug-cli -g
    node-fs-extra: npm install --save fs-extra
    Graceful: npm install graceful-fs-extra
    npm update minimatch
    npm -v minimatch
    npm install -g npm@3
    npm install -g minimatch@3.0.2
    npm -v minimatch

    Then configure Mongodb and run npm install

  • @Bri spot on. it's the bargain bin $5 droplet.

  • @Cygnus I will give this a try later, after employing common sense and reading the requirements. 1GB is reasonable. Ty

  • Swedes

    Nothing is impossible ;)

  • Anime Lovers

    I run NodeBB just fine on 512Mb. To get NPM to install properly I had to setup a swap (not recommended on SSD I know) but it was able to get NPM to work. I'm highly surprised that NPM has issues with a 512 box with just the necessities running. But whatever. NodeBB runs just fine.

    I just recently migrated my NodeBB forum to Digital Ocean so its fresh in my mind. Runs better than on my 1G virpus I had. I also used Ubuntu 14.04 since I was having issues with migrating my MongoDB, but I eventually got that all upgraded so I'm on 16.04 Ubuntu now. The NodeBB my data was from was V1.1.0. So you could try that one.

  • Gamers

    @HolyPhoenix My test forum is on Digital Ocean, and they have SSD disks. Thanks for the info!

Log in to reply

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.