Steam SSO (1.18)

Unsolved Technical Support
  • Hi,
    I'm looking for a steam SSO plugin but can't, unfortunately, find one, Are there any suggestions on how I can go about this as it's quite crucial to my forum design.


  • @pitaj Hey, thanks for the quick response.

    Yes I'm actually trying to get that working right now, but keep running into problems, I've managed to get this as the most recent error:
    Error: We were unable to log you in, likely due to an expired session. Please try again

    I believe this may be due to the BB located in a non HTTPS environment?

  • @pitaj Hey, just went and researched through a bunch of topics but I'm having no luck getting rid of this auth/callback error.

    Currently I'm using cloudflare for my SSL certs and then that leads to my docker nginx reverse proxy, that then sends you to the correct subfolder in the domain
    I.E => proxy.pass thenodebb:backend however I still am getting this issue, I've tried a whole host of things and keep ending up at the same space, here is the nginx conf

    ```server {
        # You would want to make a separate file with its own server block for each virtual domain
        # on your server and then include them.
        listen       8081;
        #tells Nginx the hostname and the TCP port where it should listen for HTTP connections.
        # listen 80; is equivalent to listen *:80;
        root                    /var/www/dir/public;
        # lets you doname-based virtual hosting
        proxy_set_header X-Forwarded-Proto https;
        #charset koi8-r;
        #access_log  logs/host.access.log  main;
        location / {
            #The location setting lets you configure how nginx responds to requests for resources within the server.
            index  index.html index.htm;
        location /auth/ {
        location /forums/{
                    proxy_set_header X-Real-IP $remote_addr;
                    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                    proxy_set_header X-Forwarded-Proto $scheme;
                    proxy_set_header X-Forwarded-Port 443;
                    proxy_set_header Host $http_host;
                    proxy_set_header X-NginX-Proxy true;
                    proxy_redirect off;
                    # Socket.IO Support
                    proxy_http_version 1.1;
                    proxy_set_header Upgrade $http_upgrade;
                    proxy_set_header Connection "upgrade";

    would really love some suggestions as to what I'm doing wrong (if you want the domain to access this I can dm it to you)

  • @bara-suffar Still having no luck with this, I'm at the point where I can't even log into the normal authentication, it just puts me onto the homepage, without any errors of any sort, really puzzled as to whats going on lol

  • Why do you have a separate route handler for auth?

    Also your proxy pass should probably be proxy_pass; of you're running nginx and nodebb on the same server.

    If the plugin is breaking your logins, you can disable it from the command line:

    ./nodebb reset -p <package name>

  • @bara-suffar I noticed you're using Cloudflare - can you see if this post helps to resolve your issue ?

  • @pitaj The /auth/ section is a route to my main website, I'm going to migrate that within the forum if I can get that working, and will get rid of it eventually.

    I've done this and now back to square 1 being the session expired. I checked the console and its pointing out that it gets a 500 error when trying to reach the callback section. I've gone over my config and haven't been able to resolve this after trying a lot of suggestions. Not sure where the issue lies now because it seems that it isn't my ngnix config.

  • @bara-suffar what is the url in config.json? It should match the url at which you access the site exactly.

  • @pitaj URL is also correct.
    I've managed to temporarily fix the issue, but I don't think its a very secure fix,
    in /src/routes/authentication.js line 124
    // next(req.query.state !== req.session.ssoState ? new Error('[[error:csrf-invalid]]') : null);
    the req.query.state == unidentified, so no matter what I did I was getting the error, however replaced it with next(); and its all working now, but still not sure why the query state is unidentified, any suggestions?

Suggested Topics

  • Simplemachines (SMF) 2.1.x import?

    Unsolved Technical Support
    0 Votes
    4 Posts

    @Themistocles-Papassilekas said in Simplemachines (SMF) 2.1.x import?:

    However, are you talking about some specific SMF exporter? I haven't seen any on the SMF side!

    They're probably talking about nodebb-plugin-import which works alongside an exporter plugin like nodebb-plugin-import-smf by providing a common API for the exporters to use (and yeah, exporter plugins have import in the name... Makes a bit of sense since nodebb-plugin-export-smf would suggest it's exporting to SMF, but it's still a bit weird)

    I'm not sure how well maintained that is honestly, but NodeBB database schema hasn't seen any major changes in the last few years - still, the best idea might be to follow what the readme offers, install NodeBB 1.12.1, import data from SMF and then upgrade NodeBB to 3.x. Though note that you'll probably want to switch to Harmony theme after upgrading, since you'll be defaulted to the old Persona theme 🙂

    The bigger question is whether the SMF plugin will work with 2.1.4, since it was tested on 2.0.3 and hasn't been updated in the last few years

  • 0 Votes
    5 Posts

    @baris dude ! thank you very much, it work

  • 0 Votes
    3 Posts

    Hello, welcome to NodeBB!

    NodeBB will run perfectly fine on node versions as low as 0.10, there is maybe only a very smaller number of third-party plugins that may require node 4.

    You have installed a Node Version Manager called n which does indeed make it easy to change node versions. n does this by copying the files from it's directory to /usr/bin/ when you use it's commands. The reason you had to do this manually probably has to do with a permissions issue.

    You are running all your commands as sudo, when none of them should be run with sudo, this can cause permissions issues and is possibly a security risk. Unfortunately, it may be too late to correct this problem. Next time, check here if you run into any issues when not using sudo.

  • 0 Votes
    6 Posts

    @julian I confirm. It is fixed.

  • 0 Votes
    2 Posts

    Ok, when I switched to using a clustered setup with nginx serving static assets this issue went away.