Fresh installation seems broken

Technical Support

Suggested Topics

  • 0 Votes
    2 Posts

    @Gliding9426 Yes, they should... when you install a plugin via NodeBB, the package.json file is updated, and the plugin is downloaded to the node_modules/ folder, along with its dependencies. Both of those are on-disk, which is ephemeral on a Docker instance.

    If package.json is updated to include the plugin, then when ./nodebb upgrade -i (or npm i, etc.) is run, the plugin will be installed alongside, automatically.

  • 1 Votes
    2 Posts

    Hi I have the same error when using npm update after upgrading to 1.19.7.
    Could not fix it yet ... 😞

  • 0 Votes
    1 Posts

    Hi everyone !!

    I am trying to install NodeBB in my local environment to test how everything goes but I am unable to perform the installation.

    I manage to do

    docker run nodebb/docker

    And it says that is live in 4567. However, when I launch localhost:4567 its stuck in a loading white screen.

    I also tried this installation with docker guide, but I am not able to install Redis, and it is the first step:

    When I try any of these commands:

    docker run --name my-forum-redis -d -p 6379:6379 nodebb/docker:centos-redis docker run --name my-forum-redis -d -p 6379:6379 nodebb/docker:ubuntu-redis

    It returns: Error response from daemon: manifest for nodebb/docker:centos-redis not found: manifest unknown: manifest unknown

    Does anybody know how to perform the installation with Docker?
    Thanks in advance.

  • 0 Votes
    3 Posts

    I was able to install it by following the instructions from here:
    I already have node.js installed on my computer. I did not install redis or nginx.
    I have a mac, so on Terminal, after I created a directory called "nodebb", I skipped the first few lines of the instructions, and just pointed to the directory I created, by using the "cd" command. I then created another directory called NodeBB inside the nodebb directory. You may skip creating two directories and just create a directory called "NodeBB". I pointed to this directory by using the cd command.
    Then this line
    "git clone -b v1.15.x ."
    was the key for me.
    After I typed that, nodebb was cloned to the directory.
    Then I ran "./nodebb setup".
    I used mongo for the database.
    When prompted, I pasted the connection string that I got from mongodb's site. I substituted "nodebb" for the database part in the string. (I set up mongodb (Cloud Atlas) beforehand). The instructions that come up on Terminal will tell you to call your database "nodebb".
    After that step, the program ran automatically and installed the files. It asked me to put in the username and password for mongodb and it also asked me to choose a name for admin and password. You might have to wait a while as it pauses for a long time after "Confirm Password". I thought there was some problem and was tempted to abort the operation, as it was taking a long time, but it did come up with further instructions after a while.
    I typed "./nodebb start" when the setup finished and then went to "localhost:4567", and this time, I was able to see a normal board, and could log in as admin.
    I write this follow-up in case another mac user has trouble installing nodebb. In the end, setup was pretty straightforward and did not involve a lot of steps. My OS is High Sierra.
    The instructions, including the ones for Linux, at the official nodebb site did not work for me.

  • 0 Votes
    1 Posts

    Hello guys,

    Just installed Nodebb to Ubuntu server with Nginx reverse proxy according to the guide (

    But on the homepage, I see only three words: "Categories", "Register", "Login". The problem is that I need to create the admin user but registration is impossible due to username validation error. Under username field I can see:

    A unique username between and characters. Others can mention you with @username.

    And whatever I type, I get:

    Username too long

    I've tried upgrading and rebuilding assets, nothing seems to help.

    No errors seen both in the browser console and in the output of ./nodebb dev

    Thank you in advance for your help!