Only some users have the issue: Connection to NodeBB has been lost, attempting to reconnect..



  • Hello I have the same problem like several people with the message "Connection to NodeBB has been lost, attempting to reconnect.."

    But it only happens for some users.

    I assume that their browser doesn't support websockets. Because the forum we set up is used in the medical industry.

    Usergroups:

    • Governmentel Health Departments
    • Hostpitals

    So my questions:

    • Are their any limitations for nodebb caused by Browser Versions or High Security Networks?
    • Can nodebb run without sockets?

    The configurations of nginx and nodebb should be correct. Because it's all setup according to the documentation.

    Running on Ubuntu 18.04 LT min on Google Cloud.
    It's working when I'm using it, and several other people. But not for some users.

    NGINX:

    server {
    
        server_name xxx.yyy.ch;
    
        location / {
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
    
            proxy_pass http://127.0.0.1:4567;
            proxy_redirect off;
    
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
        }
    
        listen 443 ssl; # managed by Certbot
        ssl_certificate /etc/letsencrypt/live/xxx.yyy.ch/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/xxx.yyy.ch/privkey.pem; # managed by Certbot
        include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
        ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
    
    }
    server {
        if ($host = xxx.yyy.ch) {
            return 301 https://$host$request_uri;
        } # managed by Certbot
    
    
        listen 80;
    
        server_name xxx.yyy.ch;
        return 404; # managed by Certbot
    
    
    }
    

    Config.json:

    {
        "url": "https://xxx.yyy.ch",
        "secret": "bd50dacd-2089-840c-8704-6d3cfe8da3e4",
        "database": "mongo",
        "mongo": {
            "host": "127.0.0.1",
            "port": 27017,
            "username": "",
            "password": "",
            "database": "nodebb",
            "uri": "mongodb://admin:password@localhost:27017"
        }
    }
    


  • And as suspected, it's about internal it restrictions of the user:

    aTODO___23_712_-samuel_schmid_modeso_ch-_Modeso_Mail.png

    Is there anything I can do on my side?


  • GNU/Linux Admin

    Ah, that's very unfortunate!

    At this time, websockets are required for almost all of the write operations in NodeBB. That's due to change in v2, but that is a ways away yet.

    Is there no way those IT administrators can allow for websockets to be whitelisted?


  • Global Moderator

    Several operations are supported: login, logout, pagination, posting I think are.



  • Thanks for your replies!

    @julian This will be the solution in this case.

    @PitaJ Great, Thanks.

    Currently I don't have time to join the development community of contributors. If I have in future, I will take a look into code to write a backup function also for the registration.

    The software is really great, congratulations for the community.


Log in to reply
 

Suggested Topics

  • 6
  • 3
  • 2
  • 3
  • 4
| |