nodebb v1.1.1 installation



  • I get
    'child_process.js:422
    throw new ERR_INVALID_ARG_TYPE('options.cwd', 'string', options.cwd); '
    while trying to start NodeBB


  • Global Moderator

    v1.1.1 or v1.11.1 ?

    What version of Node?

    What command are you running that results in that error?

    Can you post the whole output?



  • @dragan-anastasov @PitaJ I am moving my Forum to a new server and am running into the same problem.

    When I go to start up the NodeBB I get the following:

    $ ./nodebb start
    
    Starting NodeBB
      "./nodebb stop" to stop the NodeBB server
      "./nodebb log" to view server output
      "./nodebb restart" to restart NodeBB
    
    child_process.js:438
        throw new ERR_INVALID_ARG_TYPE('options.cwd', 'string', options.cwd);
        ^
    
    TypeError [ERR_INVALID_ARG_TYPE]: The "options.cwd" property must be of type string. Received type function
        at normalizeSpawnArguments (child_process.js:438:11)
        at Object.spawn (child_process.js:553:16)
        at Function.module.exports.daemon (/usr/share/nodebb/devforum/node_modules/daemon/index.js:50:31)
        at module.exports (/usr/share/nodebb/devforum/node_modules/daemon/index.js:25:20)
        at /usr/share/nodebb/devforum/loader.js:221:21
    

    My Node and NPM versions are:

    $ node -v
    v11.10.0
    $ npm -v
    6.7.0
    

    NodeBB version is 1.4.5. Yes, that is correct, 1.4.5. I apologize for hijacking this thread.

    Thoughts?


  • Global Moderator

    @rod downgrade to Node 10. We don't support Node 11 yet.



  • @PitaJ I downgraded to Node 10 (dumped and rebuilt the server actually) and am still getting an error. This is it:

     ./nodebb start
    
    Starting NodeBB
      "./nodebb stop" to stop the NodeBB server
      "./nodebb log" to view server output
      "./nodebb restart" to restart NodeBB
    
    child_process.js:422
        throw new ERR_INVALID_ARG_TYPE('options.cwd', 'string', options.cwd);
        ^
    
    TypeError [ERR_INVALID_ARG_TYPE]: The "options.cwd" property must be of type string. Received type function
        at normalizeSpawnArguments (child_process.js:422:11)
        at Object.spawn (child_process.js:532:38)
        at Function.module.exports.daemon (/usr/share/nodebb/devforum/node_modules/daemon/index.js:50:31)
        at module.exports (/usr/share/nodebb/devforum/node_modules/daemon/index.js:25:20)
        at /usr/share/nodebb/devforum/loader.js:221:21
        at FSReqWrap.oncomplete (fs.js:141:20)
    

    Versions are:

    $ node -v
    v10.15.1
    $ npm -v
    6.4.1
    
    Nodebb: 1.4.5
    

  • Global Moderator

    @rod said in nodebb v1.1.1 installation:

    ERR_INVALID_ARG_TYPE

    Try Node 8 and Node 6, and let me know if they work. If you're trying to upgrade NodeBB, then just upgrade to the latest NodeBB and run the upgrade, you don't need to get 1.4.5 working first.

    (Backup your database of course)



  • @PitaJ Thanks, that seemed to have worked. I have 1.11.2 running now but with some problems. I opened another thread about one of them.



  • @rod said in nodebb v1.1.1 installation:

    @PitaJ Thanks, that seemed to have worked. I have 1.11.2 running now but with some problems. I opened another thread about one of them.

    As general practice, keeping NodeBB on old versions isn't a great idea.


  • Gamers

    I agree. It has all types of holes and nasty bugs. 😕



  • @PatheticMustan said in nodebb v1.1.1 installation:

    I agree. It has all types of holes and nasty bugs. 😕

    Plus new features, better tested upgrade paths, etc.


  • Admin

    Yeah, old versions of NodeBB suck, I don't know who the developers of that crap was... 😝



  • @julian said in nodebb v1.1.1 installation:

    Yeah, old versions of NodeBB suck, I don't know who the developers of that crap was... 😝

    What were they thinking? 😉


Log in to reply
 

Suggested Topics

| |