Nginx



  • Can someone please paste their full nginx.conf and cofig.json for nodebb?

    I can now seem to get it work. One day it was fine, now its not.



  • Bump Post



  • if you still have issues post your files, obviously leaving out sensitive info and one can help you further



  • @phit I need help with linking my domain. Those links didnt work. Only the IP setup works. When I try to configure my domain, it breaks. The page doesnt load.

    The domain is pointed to the server.


  • Anime Lovers

    @chrispy show screen your nginx config and config.json



  • @alex-bro will do in about an hour when I get home.



  • @alex-bro Ok,

    Heres my Nginx config -->

    # For more information on configuration, see:
    #   * Official English Documentation: http://nginx.org/en/docs/
    #   * Official Russian Documentation: http://nginx.org/ru/docs/
    
    user nginx;
    worker_processes auto;
    error_log /var/log/nginx/error.log;
    pid /run/nginx.pid;
    
    # Load dynamic modules. See /usr/share/nginx/README.dynamic.
    include /usr/share/nginx/modules/*.conf;
    
    events {
        worker_connections 1024;
    }
    
    http {
        log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                          '$status $body_bytes_sent "$http_referer" '
                          '"$http_user_agent" "$http_x_forwarded_for"';
    
        access_log  /var/log/nginx/access.log  main;
    
        sendfile            on;
        tcp_nopush          on;
        tcp_nodelay         on;
        keepalive_timeout   65;
        types_hash_max_size 2048;
    
        include             /etc/nginx/mime.types;
        default_type        application/octet-stream;
    
        # Load modular configuration files from the /etc/nginx/conf.d directory.
        # See http://nginx.org/en/docs/ngx_core_module.html#include
        # for more information.
        include /etc/nginx/conf.d/*.conf;
    
    server {
        listen 80;
    
            server_name mcdiscuss.com;
    
        location / {
    
            allow all;
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
    
            proxy_pass http://127.0.0.1:4567/;
            proxy_redirect off;
    
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
    
        }
    }
    
    # Settings for a TLS enabled server.
    #
    #    server {
    #        listen       443 ssl http2 default_server;
    #        listen       [::]:443 ssl http2 default_server;
    #        server_name  _;
    #        root         /usr/share/nginx/html;
    #
    #        ssl_certificate "/etc/pki/nginx/server.crt";
    #        ssl_certificate_key "/etc/pki/nginx/private/server.key";
    #        ssl_session_cache shared:SSL:1m;
    #        ssl_session_timeout  10m;
    #        ssl_ciphers HIGH:!aNULL:!MD5;
    #        ssl_prefer_server_ciphers on;
    #
    #        # Load configuration files for the default server block.
    #        include /etc/nginx/default.d/*.conf;
    #
    #        location / {
    #        }
    #
    #        error_page 404 /404.html;
    #            location = /40x.html {
    #        }
    #
    #        error_page 500 502 503 504 /50x.html;
    #            location = /50x.html {
    #        }
    #    }
    
    }
    

    heres my nodebb config -->

    {
        "url": "http://127.0.0.1:4567",
        "secret": "Its a secret",
        "database": "redis",
        "port": 4567,
        "redis": {
            "host": "127.0.0.1",
            "port": "6379",
            "database": "0"
        }
    }
    

    edited by pitaj, please use triple-ticks (```) for code blocks


  • Global Moderator

    By convention, nginx server configs should be put it /etc/nginx/sites_available and linked into /etc/nginx/sites-enabled. I suggest following the linked documentation above for how to set up nginx.



  • @pitaj said in Nginx:

    By convention, nginx server configs should be put it /etc/nginx/sites_available and linked into /etc/nginx/sites-enabled. I suggest following the linked documentation above for how to set up nginx.

    That;'s not entirely correct. Not every spin follows this.. wacky pattern. :)


  • Anime Lovers

    @chrispy said in Nginx:

    mcdiscuss.com

    I think you shuld add this place your domain name

    And i think you shuld add your nginx config in:

    /etc/nginx/sites_available 
    

    and linked into

    /etc/nginx/sites-enabled
    

    I first time see that someone put domain info in nginx.config )))



  • judging by your configs you haven't read either docs link I had sent you, don't expect people to help you if you don't bother reading the documentation..



  • @alex-bro Thank you! It worked. @phit I tried that but it didnt work. This whole time, I had to run ./nodebb reset -p for it to take action. Idk why.


  • Anime Lovers


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.