How to install NodeBB on Debian 8 (jessie)?

Technical Support
  • The official documentation unfortunately only covers Debian 6 and 7, but not 8. I'm not sure how to proceed. Any experience with the installation of NodeBB on Debian 8.5? Thank you very much, your help is much appreciated!

  • Try to use the guide for Debian 7. Much should be the same! If you run into specific error you can ask here 🙂

  • @Jenkler Okay thanks. I didn't know what to do since it says "ONLY Debian 7" and I'm kind of new to all this. So I just followed the documenation until the "clone this repository" step (which did not work, because there is no such directory ("or file"). Here the errors from the other steps:

    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "de_DE.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to a fallback locale ("de_DE.UTF-8").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory

    dpkg: error processing package redis-server (--configure):
    subprocess installed post-installation script returned error exit status 1
    Processing triggers for libc-bin (2.19-18+deb8u4) ...
    Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.31.1-2+deb8u5) ...
    Processing triggers for systemd (215-17+deb8u4) ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    cd /path/to/nodebb/install/location
    -bash: cd: /path/to/nodebb/install/location: file or directory not found

    I hope someone can help me here. Thank you very much! I'd love to run nodebb!

  • You're actually supposed to create a directory. Assuming you are a regular user and don't need multiple nodebbs, the home directory should work fine. (that's what i use)

    cd ~
    git clone -b v1.x.x nodebb
  • @Jenkler Well, that's what I thought. However, what about the other errors? Not relevant?

  • I'm not really sure, never seen those errors. But it seems to only have failed on a post-installation script for redis-server. So it might still work.

    tbh, you probably want to remove the redis-server package and install it from source. This is the method I see recommended the most.

  • @yariplus You're right, it's running now although I got these errors.

    However, I still have to use port 4567 instead of a sheer domain name. Tried to follow this tutorial:

    Nginx in my case was installed through plesk and I can't find the config file nor do I know about possible consequences/effects on my other sites hosted on the same server via plesk. Any suggestion on how to proceed to be able to remove the port? Thanks!

  • If you use NGinx for the other websites that you host, and when you want to install it to a subdomain which is not being used now, there will not be no problems using that tutorial. Make a new file (so do not use the default setup, or an alias that is already there) at /etc/nginx/sites-available and a softlink to /etc/nginx/sites-enabled

    touch /etc/nginx/sites-available/nodebbforum
    ln -s /etc/nginx/sites-available/ /etc/nginx/sites-enabled/nodebbforum

    You can use the setup of the tutorial then by changing the file /etc/nginx/sites-available/nodebbforum. Make sure that server_name is set to the correct subdomain.

  • @JasperNL There are no such directories as "sites-available" or "sites-enabled" there. I forgot to mention: Plesk installed the newest version of NGinx: 1.11.1.

    By the way, me being relatively new to this kind of work: How come "ls -al" is not showing me the "etc" directory in the root although I can access it via "cd"?

    Thank you very much for your help! 👍

  • @Hillcow Sites-available and sites-enabed does only exist if you install the nginx from the OS repository if you install from any other repository you will only have conf.d which is a good place to put your configuration with the small change that the files in there need to end with .conf extensions.

  • this should work for you, you should've mentioned you are using plesk on the server early on
    since it completely changes how apache2/nginx configuration works

Suggested Topics