Crash on /search



  • Upon anyone trying to search anything, I get the following beautiful error message:

     MongoError: exception: $sort key ordering must be specified using a number
        at Function.MongoError.create (/home/popey/nodebb/node_modules/mongodb/node_modules/mongodb-core/lib/error.js:31:11)
        at queryCallback (/home/popey/nodebb/node_modules/mongodb/node_modules/mongodb-core/lib/cursor.js:200:36)
        at Callbacks.emit (/home/popey/nodebb/node_modules/mongodb/node_modules/mongodb-core/lib/topologies/server.js:119:3)
        at null.messageHandler (/home/popey/nodebb/node_modules/mongodb/node_modules/mongodb-core/lib/topologies/server.js:371:23)
        at Socket.<anonymous> (/home/popey/nodebb/node_modules/mongodb/node_modules/mongodb-core/lib/connection/connection.js:301:22)
        at Socket.EventEmitter.emit (events.js:95:17)
        at Socket.<anonymous> (_stream_readable.js:746:14)
        at Socket.EventEmitter.emit (events.js:92:17)
        at emitReadable_ (_stream_readable.js:408:10)
        at emitReadable (_stream_readable.js:404:5)
        at readableAddChunk (_stream_readable.js:165:9)
        at Socket.Readable.push (_stream_readable.js:127:10)
        at TCP.onread (net.js:526:21)
    Clustering enabled: Spinning up 1 process(es).
    

    Considering this is literally a clean build, anyone have any ideas of what may be causing it?


  • Admin

    What version of mongodb are you using? I haven't seen that error before.



  • @baris

    ~/nodebb :) > mongod --version
    db version v2.4.9
    Thu Jun 16 18:57:38.811 git version: nogitversion
    

  • Plugin & Theme Dev

    @Alexander-Craggs MongoDB, version 2.6 or greater is required


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.