Issues installing nodebb



  • So I'm trying to install nodebb on a debian vps server I have.

    I've followed the instructions here but I'm unable to get it to work somehow.

    I've already installed all the required software, including nodebb, ran the basic setup and started the service but I cant seem to open it on any of the possible URLS

    I have nginx installed (altough Im pretty sure it has default config) and cloudflare is active for the main domain not sure if that is an issue.

    nodebb is installed in the public_html/forum/nodebb/ directory but I want to access it from domain.com/forum. My aim is to link it with a wordpress instalation on the main domain. I can access domain.com/forum/nodebb/nodebb but the only thing I see is this

    Appreciate any help.


  • Translator

    Try this domain its free for 12 months and its easy to use
    FreeNom.com



  • @Zerion said:

    Try this domain its free for 12 months and its easy to use
    FreeNom.com

    ?????

    I have a domain with a site currently installed already, I was just specifying the directories in the domain and I hide it for privacy reasons


  • GNU/Linux

    NodeBB is not powered by PHP but by node.js.
    So basically it does not belong anywhere within the public_html directory of you LAMP server.
    For security reasons move it somewhere else (it doesn't really matter where, as long that location is not publicly visible like public_html is).

    When you've followed this part of the guide, your NodeBB instance should be running on the specified port within ./nodebb setup. You now have to configure a proxy to link a public URL to your local NodeBB instance. You should also call ./nodebb restart after moving NodeBB out of the public_html directory to ensure everything works fine.



  • @frissdiegurke

    STill not able to install it, anytime I try to access the domain with the specified port it just loads forever and never opens. I've set up the proxy and everything else as the instructions. i had no idea what to do now.

    I see this when using ./nodebb log
    alt text

    Also anytime I run the ./nodebb setup it just stops in the middle of it and cant get any answer back from putty

    Also my config.json files has this

    {
    "url": "mainurl",
    "secret": "secretname",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "",
    "database": "0"
    }
    }

    Not sure if having no password or database set as 0 is the recommended.



  • @Kaneco Are you using Nginx or Apache as your webserver? Do you have the proxy set to handle connections to port 4567?


  • Admin

    To piggyback off of @rod's line of questioning... can you access the forum when you navigate to the ip:port directly?


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.