Redis Databse, Fresh Linux Install.



  • So I am doing the host myself on Digital ocean route.

    I was following this guide.

    And I got as far as the "setup" for nodeBB itself.

    Then I get This error:

    19/9 23:39 [4144] - error: Your Redis version is not new enough to support NodeBB

    How do I go about updating the Redis version inside of this node


  • Translator

    Redis will not update to the latest version on Ubuntu since (if I'm correct) it isn't updated to the latest version on apt-get, to fix this you need to uninstall redis and follow this guide to manually compile and install the new Redis version.


  • Admin

    A simpler way to get a newer version:

    $ sudo add-apt-repository ppa:chris-lea/redis-server
    $ apt-get update
    $ apt-get install redis-server
    


  • Will attempt the simpler way posted by Julian here in the next hour.

    I will update you, and thanks very much for help so far! Hope to gain some experience in node myself and be able to contribute back.


  • Translator

    @julian @zombie for some reason my server decided to be evil and completly ignore the repository, thats why I included the manual compiling. Anyways good luck.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.