• This post is deleted!
  • Community Rep

    Weird, works for me on my forum (I'm on master), maybe there was a bug that got fixed at some point..

    Dumb question, but did you make sure to hit the Save Changes button at the top right?

    Also, are you primarily a Minecraft server? I need more testers and user feedback for my plugin. (Currently only have one tester.) Lmk if you're interested.

  • Hi,
    Thanks for the reply.
    Yes, I am 100% sure that I saved it as after 2 reloads a restart and me clearing my cache it still didn't work, yet the setting said it was enabled.

    It's really strange, as if you go to https://forums.jamesj.me/ and hit 'Home' or 'DatPixel Entertainment' it shows you the warning page, any other link nope.

    And yes, we are primarily a Minecraft server. Feel free to email me if you're looking for beta testers (you can get my email on my website [click my profile, then website -- I don't want crawlers :p])

  • NodeBB Admin

    Can you guys post your nodebb revision as well.

  • Community Rep

    I'm on 9e1d5c8 and it works correctly.

  • @JamesJ @yariplus here is how the whole outgoing link thing works...

    The warning page only works if the links are not setup to open in a new tab/window.

    There is an option under user settings that lets every user specify if they want links in posts to open in new window. If the option is checked under user settings, every link opens in a new tab for that user and they don't see the warning page because they are not actually leaving the origin site and the link is opening in a new window.

    Screen Shot 2015-08-13 at 11.09.56 PM.png

    This used to be the only option and it let's the user decide how they want it to work.

    Now there is a new option in the nodebb-plugin-markdown plugin settings page that let's admin specify to have every link open in new tab/window.

    Screen Shot 2015-08-13 at 11.15.45 PM.png

    I believe this was added recently. If this option is checked, every link is opened in a new window and just ignores the setting under user settings (this is wrong if you ask me).

    So, even if you have the outgoing links warning enabled... it depends on two other settings if it shows up or not.

  • Thanks for all the replies,
    I got it work, it was in fact to do with the markdown plugin (thanks @pichalite!)

    I do have another issue however, the times are a little messed up on my forums. This was reported to me by one of our moderators as I hadn't noticed it. It appears that all of the times on the website are being shown as the machine's local time (which is located in Dallas, USA) so for me it shows "7 hours ago" even if I've just posted a topic.. You can see an example of this here, https://f.jamesj.me/3e4i
    Am I meant to have a dependency installed (that I don't)?


  • Bump....?

  • This post is deleted!

Suggested Topics

| | | |