Infinite Request Loop - Wrong Post Count



  • I have a specific thread on my forum with a post count of 34. There are 33 posts and 1 purged post in the thread (which may be a bug - seems like it should not be showing deleted posts in the count, or it could be the result of a network failure or something). Clicking the double-down-arrow on the menu bar on this thread results in an infinite request loop in your browser (you can see the page "flicker" and the network console goes berserk). Happens in both IE and Chrome (fully locks up the IE process if I let it go on for very long).

    The double-down-arrow link, of course goes to /thread/34 and loading this link directly in your browser does duplicate the issue. Going to /thread/35 redirects the browser back to /thread/34, still causes the problem. Going to /thread/33 takes you to the final post on the page, as it should. I assumed that this was the root of the problem and was going to report it as a bug. I purged a post from this thread and I suspect that may be where the thread count got off. I've tried to recreate that with other threads but I am unable to do so.

    Going over the post count on another thread (e.g. /otherthread/9001) doesn't cause a problem because it just redirects back down to the correct post count.

    How do I fix this?



  • Can you post a link to the thread that has this problem? Also post nodebb git revision, theme used, if pagination is used or infinite scroll.



  • Can't post a link. Infinite scroll, 0.6.x. master branch.



  • Forgot to mention - unmodified vanilla theme.

    This is a moderately clean install, but running on a slow system (I moved it off my previous VM host to replace the underlying hypervisor and it will be going back to the faster machine once that's done, so just a temporary thing, but I think it may be contributing). I installed a fresh copy of NodeBB and reinstalled my plugins and restored the redis dump on the new server. It's still on what I would consider adequate hardware for nodebb (single 3.2ghz AMD core with 1GB RAM) and fairly light usage (~10 posts per day, perhaps).

    The thread in question was created after the move, though, so it wouldn't have been corrupted by the restore.

    It could also be plugin related/etc.

    I think a good first step to fixing it might be to fix the post count in redis? I don't really know much about how nodebb interacts with the data store, though, so if you could tell me what to look at for that, it would help.



  • Plugin list, all reported as latest in ACP but emoji-extended was installed from npm commandline because the ACP installs a non-compatible version meant for 0.7.0:

    nodebb-plugin-color
    nodebb-plugin-dbsearch
    nodebb-plugin-emailer-mailgun
    nodebb-plugin-emoji-extended (@0.4.1-4)
    nodebb-plugin-imgur
    nodebb-plugin-markdown
    nodebb-plugin-mentions
    nodebb-plugin-soundpack-default
    nodebb-plugin-spam-be-gone
    nodebb-plugin-topic-badges
    nodebb-plugin-twitch
    nodebb-plugin-youtube-lite
    nodebb-widget-essentials



  • I suppose I should also mention I am running:
    Ubuntu 14.04.2 LTS (GNU/Linux 3.16.0-33-generic x86_64)
    nodejs v0.12.0
    redis 2.8.19


  • Global Moderator

    @Shaun said:

    0.6.x. master branch.

    That doesn't make sense. You're either on v0.6.x from the v0.6.x branch, or you're on v0.7.0-dev from the master branch. Which one are you on?



  • Sorry, I'm an idiot.

    On branch v0.6.x
    Your branch is up-to-date with 'origin/v0.6.x'.



  • devconsole.PNG

    That's 154 requests ~25 seconds before I shutdown the Chrome tab. It just keeps requesting those two resources over and over again.

    PS: Post count is now up to 41 (but is really 40), in case you're wondering about the requested items.


  • Admin

    Would be nice if we could get access to the thread so we can have a look at it ourselves. Have you tried disabling all plugins and seeing if that made a difference?



  • @psychobunny no, I have not, but I suspect it may be plugin related or something screwy about this thread in the database. I have been distracted by a million other things and one misbehaving thread wasn't my priority, but I will look and see if I can figure something else out.


Log in to reply
 

Suggested Topics

  • 3
  • 12
  • 3
  • 1
  • 2
| |