Turn off warning in console


  • GNU/Linux

    Hello,

    I am using the v0.7.0-dev version of NodeBB. My console is throwing warn messages for nearly every plugin / theme. They always have the same message:

    4/4 xx:xx [xxxxx] - warn: [plugins/nodebb-plugin-xxxxxxxxxx] This plugin may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing.
    4/4 xx:xx [xxxxx] - warn: [plugins/nodebb-plugin-xxxxxxxxxx] In the event of an unresponsive NodeBB caused by this plugin, run ./nodebb reset plugin="nodebb-theme-xxxxxxxxxx".
    

    This also happens with e.g. "official" plugins as nodebb-plugin-emoji-extended.

    I looked at plugins who don't throw these warn messages & not all of them but some have something like:

    "nbbpm": {
        "compatibility": "^x.x.x"
    }
    

    In their package.json, but e.g. nodebb-plugin-emoji-extended also has

    "nbbpm": {
        "compatibility": "^0.7.0"
      }
    

    in their package.json and is still throwing these warns. So I don't really have a clue what is causing these warns.

    That is very annoying, as I am not really able to focus on the real errors I want to see when I program or design. So is there a way to disable warn messages in the console?



  • ^0.7.0 is not the same as 0.7.0-dev. The -dev is there for that exact reason. Once it's stable. It loses the -dev part. 🙂


  • GNU/Linux

    Okay. Thanks for the reply. So there is no option to just turn the warnings off somewhere?


  • Swedes

    Better to use 0.6.x as prod system. 0.7.x is under heavy development 🙂


  • GNU/Linux

    @Mikael 0.7.x is under development but "stable". This forum is running 0.7.x for example. I've been always using the development versions & never had serious bugs.


  • Plugin & Theme Dev

    @ApfelUser As to my knowledge 0.7.x isn't considered as "stable", this is the point. 0.7.0-dev is syntactically a pre-release version of 0.7.0 (which is the reason why ^0.7.0 doesn't match it btw.) so there in fact is no 0.7.x yet.

    This forum is always running a near-master version to give us a preview of the upcoming features. It's generally not a good idea to do so for production even so I agree that it's doable since most fatal bugs get fixed pretty fast.

    That I use ^0.7.0 anyways is intended therefor those users who use 0.7.0-dev get those warnings because I don't like how many users within this board ask for help with 0.7.0-dev even so the -dev should be hint enough 😄 but I just leave those questions to the others to answer xD


  • Admin

    I agree they're very "in your face", but this was a serious issue with 0.5 to 0.6, and as we didn't have a system to deal with versioning (we do now), it was very important to spam this message on startup.

    It would be ideal to concatenate all of these messages and display the warning once.


  • GNU/Linux

    I am not using this for production, and have no clue why you think I do 😄

    I am just developing some plugins and themes & would like to focus on the important errors my plugin / theme throws. Right now I can't even see my errors sometimes because they pass by so fast due to the large amount of warns.

    @julian yeah I think that would be a great idea.


 

| |