• I am upgrading from 2.5.3 -> 2.5.7, and get this error on build:

    2022-10-16T15:17:04.734Z [4567/392256] - error: [build] Encountered error during build step
    Error: Cannot find module 'progress-webpack-plugin'
    Require stack:
    - /opt/nodebb/webpack.prod.js
    - /opt/nodebb/src/meta/build.js
    - /opt/nodebb/src/cli/manage.js
    - /opt/nodebb/src/cli/index.js
    - /opt/nodebb/nodebb
        at Function.Module._resolveFilename (node:internal/modules/cjs/loader:956:15)
        at Function.Module._load (node:internal/modules/cjs/loader:804:27)
        at Module.require (node:internal/modules/cjs/loader:1028:19)
        at require (node:internal/modules/cjs/helpers:102:18)
        at Object.<anonymous> (/opt/nodebb/webpack.prod.js:5:24)
        at Module._compile (node:internal/modules/cjs/loader:1126:14)
        at Object.Module._extensions..js (node:internal/modules/cjs/loader:1180:10)
        at Module.load (node:internal/modules/cjs/loader:1004:32)
        at Function.Module._load (node:internal/modules/cjs/loader:839:12)
        at Module.require (node:internal/modules/cjs/loader:1028:19)
    2022-10-16T15:17:04.735Z [4567/392256] - error: Error: Cannot find module 'progress-webpack-plugin'
    Require stack:
    - /opt/nodebb/webpack.prod.js
    - /opt/nodebb/src/meta/build.js
    - /opt/nodebb/src/cli/manage.js
    - /opt/nodebb/src/cli/index.js
    - /opt/nodebb/nodebb
        at Function.Module._resolveFilename (node:internal/modules/cjs/loader:956:15)
        at Function.Module._load (node:internal/modules/cjs/loader:804:27)
        at Module.require (node:internal/modules/cjs/loader:1028:19)
        at require (node:internal/modules/cjs/helpers:102:18)
        at Object.<anonymous> (/opt/nodebb/webpack.prod.js:5:24)
        at Module._compile (node:internal/modules/cjs/loader:1126:14)
        at Object.Module._extensions..js (node:internal/modules/cjs/loader:1180:10)
        at Module.load (node:internal/modules/cjs/loader:1004:32)
        at Function.Module._load (node:internal/modules/cjs/loader:839:12)
        at Module.require (node:internal/modules/cjs/loader:1028:19)
    
  • GNU/Linux Admin

    Did you run ./nodebb upgrade? It sounds like you don't have the right dependencies installed.


  • Try running npm install then trying again


  • Same error

  • GNU/Linux Admin

    Did you run ./nodebb upgrade? It sounds like you don't have the right dependencies installed.


  • No, I did not. It worked after I did so. Somehow I missed that obvious section...

  • Topic has been marked as solved   julianJ   julian 

Suggested Topics

| | | |