Unsolved Content is Invisible After 1.19.2 Update

  • @PitaJ I used Edge browser. I'm using a set of plugin. But last time I installed it a long time ago for an older version of Nodebb. The problem appeared after the upgrade.

    Have you tried clearing your cache?


    Have you tried rebuilding again?

    1.19.2 β€” yes
    1.19.3 β€” not yet

  • Another update on the topic:

    1. Moved the entire forum to a new server.
    2. The list of activated plugins:
    • nodebb-plugin-composer-default
    • nodebb-plugin-dbsearch
    • nodebb-plugin-emailer-sendgrid
    • nodebb-plugin-emoji
    • nodebb-plugin-emoji-android
    • nodebb-plugin-markdown
    • nodebb-plugin-mentions
    • nodebb-rewards-essentials
    • nodebb-theme-persona
    • nodebb-widget-essentials
    1. The problem remains
  • Global Moderator Plugin & Theme Dev

    Do you encounter any errors when building? What is your reverse proxy config?

  • Yes, I've got a few warnings:


    What is your reverse proxy config?

    Please, tell me how I can check it?

  • Global Moderator Plugin & Theme Dev

    @Aleksei have you set up NodeBB to be accessed publicly with nginx or anything? That's your reverse proxy. If you're just using it locally you won't have one.

  • @PitaJ ah, got it. Yes I did it: Here it is: https://forum.c4d.space/
    But I cannot guarantee that you will see the problem immediately, because I still couldn't figure out the steps to reproduce the issue.

  • Global Moderator Plugin & Theme Dev

    I wasn't asking for your site link, though that could be helpful.

    I was saying that nginx is your reverse proxy, so you should provide your nginx config.

    Also try restarting nginx.

  • Below is my nginx config:
    After making any changes to nginx settings I do in console 2 commands:
    nginx -t
    systemctl restart nginx

    map $sent_http_content_type $expires {
        default                    off;
        text/html                  epoch;
        text/css                   max;
        application/javascript     max;
        ~image/                    max;
        font/woff2		           max;
        application/font-woff2	   max;
        application/x-font-woff	   max;
        application/octet-stream   max;
    server {
    	server_name forum.c4d.space www.forum.c4d.space;
    	root /var/www/forum/public;
    	index index.html;
    	error_page 502 /502.html;
    	charset UTF-8;
    	client_max_body_size 5M;
        location / {
        	add_header Strict-Transport-Security "max-age=15768000" always;
        	add_header X-XSS-Protection "1; mode=block";
            add_header X-Frame-Options "SAMEORIGIN";
            add_header X-Content-Type-Options nosniff;
            add_header Referrer-Policy "strict-origin-when-cross-origin";
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
            proxy_set_header Host $http_host;
            proxy_set_header X-NginX-Proxy true;
            proxy_redirect off;
            # Socket.IO Support
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
    	expires $expires;
    	listen 443 ssl http2;
        ssl_certificate /etc/letsencrypt/live/forum.c4d.space/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/forum.c4d.space/privkey.pem; # managed by Certbot
        include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
        ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
    server {
        if ($host = www.forum.c4d.space) {
            return 301 https://$host$request_uri;
        } # managed by Certbot
        if ($host = forum.c4d.space) {
            return 301 https://$host$request_uri;
        } # managed by Certbot
        listen 80;
    	listen [::]:80;
    	server_name forum.c4d.space www.forum.c4d.space;
        error_page 502 /502.html;
        return 404; # managed by Certbot
  • Global Moderator Plugin & Theme Dev

    Visiting your forum now, it appears to be working fine. Are there still issues on your end?

    Are you having issues on https://forum.c4d.space/ or only https://www.forum.c4d.space/ ? NodeBB only knows really works when served at a single address. What is the URL in config.json? I suggest redirecting www. to the main URL.

  • Visiting your forum now, it appears to be working fine. Are there still issues on your end?

    I'll be monitoring the status. I can't reproduce the issue. It happens occasionally.
    I always access it via https://forum.c4d.space/ and this is the URL in config.json

Suggested Topics

| | |

Β© 2014 – 2022 NodeBB, Inc. β€” Made in Canada.