• Hello,
    I do not seem to get the emojis to work in my forum. The code gets printed but in the preview the icon is not there and is also missing when submitted.
    I read in other posts to install nodebb-plugin-emoji-extended but in my admin tools I cannot find this plugin šŸ¤·
    Probably I am missing something obvious, can anyone help me?
    Regards


  • If you go YOURDOMAIN.TLD/admin/extend/plugins#download
    and type emoji in Plugin Search field, can't you see the plugin? (be sure to have selected the "Find Plugins" tab)

    3935c10b-4ae3-42a3-b6ca-fef5cef3953c-image.png

  • Global Moderator Plugin & Theme Dev

    @greyteapot do not install emoji-extended. It's features are incorporated into the normal emoji plugin and it is outdated and deprecated.

    You need to have nodebb-plugin-emoji installed and enabled. You also need to have at least one emoji pack installed and enabled, such as nodebb-plugin-emoji-android. Then you need to rebuild and restart.

    It should work from there.


  • @pitaj @greyteapot

    Thank you for your reply. I installed the two Plugins but the emoji will not show in preview or when published. on the left side the code appears, when I select an emoji but on the right side there is no emoji... and when i publish there is also no emoji.

    Do you have an idea why?

    4dbff2a5-8376-449e-9745-b4470b82d232-image.png

  • Community Rep

    I can say Iā€™m encountering this problem also and had not reported it yet. (v1.16.)

    Emoji appear as broken links but a single page refresh often bring them back. Sometimes it stops. Then returns as an issue.

    They emoji will appear in the menu drop down or auto-fill suggestion, but when the post is commit again broken.

  • Global Moderator Plugin & Theme Dev

    @omega

    šŸ¤” what version of the plugin are you using?

    Try Building Emoji Assets from the emoji admin page, waiting 30sec, then running a rebuild and restart.

  • Community Rep

    @pitaj

    Initially these 2:

    https://github.com/NodeBB/nodebb-plugin-emoji (3.4.3)
    https://github.com/NodeBB/nodebb-plugin-emoji/tree/master/packs/android (2.0.1)

    Did many rebuilds both of emoji and forum (1.16) via ACP.

    I have uninstalled the Android and I'm trying gout the Apple - https://github.com/NodeBB/nodebb-plugin-emoji/tree/master/packs/apple (2.0.1)

    Note: Sometimes I need to refresh the plugins > emoji page in the ACP, to get the "Buil dEmoji" button to do it's thing.


  • @omega

    does the apple option work in your forum?

  • Global Moderator Plugin & Theme Dev

    @majr are you still having issues? Any errors in server logs or in the browser? Does the build emoji button complete successfully, showing a success message? What version of Node are you using?

  • Community Rep

    @MAJR @PitaJ

    Hey so I also ran the following in the cli just in case:

    npm upgrade nodebb-plugin-emoji

    Also:

    ./nodebb upgrade-plugins

    Then finally,

    ./nodebb build

    I also update npm to version 7.5.3 > 7.5.4

    Things do seem more stable but I am not ready yet to pronounce it issue free. Give it 24/48 hours and a checking on few other devices later and I'll update.

  • Community Rep

    Nope this is still behaving strangely.

    I have seen a warning in the log about the emoji plugin not being compatible!

    Emojis present on first page load as broken images, a page refresh displays them. Navigate away and navigate back and they are broken again.

    The Build Emoji button has always completed successfully in my experience.

    Sometimes I try then also a full rebuild via the ACP. None of this seems to make a difference.

    Finally, I tried to create a custom emoji, while it saved, I had to buy;/restart to get it to appear int he selector panel.

    Tried a custom emoji, same deal, it appears as a broken image, refresh's and it's there. Nav away and back to page, all broken again.

    Maybe there is something at the nginx level that needs to be addressed.


  • @pitaj @omega

    I could not get it to work.
    I get error messages:
    When i install the ...android it says to require a peer of nodebb-plugin-emoji@^2.0.0 but none is installed
    I change it - No difference

    When I go for apple it says...requires a peer of nodebb-plugin-emoji@^3.4.2 but none is installed
    I change it - No difference

    I also have this message but I do not know what it means ???:
    BEGIN emojis -->
    | ^^^^^^ emojis could refer to the top-level value emojis or the .emojis property of the current element, so compiler must emit code for both cases
    | note: Migrate to modern syntax to avoid the ambiguity. This will become an error in the future.

    Outcome always:
    6d7211df-58e2-462a-864c-3988bf7f2a4f-image.png

    @omega I am using nginx as well. What do you suggest could be the Problem?

  • Community Rep

    @majr said in Cannot get emojis to work:

    nodebb-plugin-emoji

    Do you have nodebb-plugin-emoji installed?

  • Global Moderator Plugin & Theme Dev

    @omega can you look for 404 errors in your browser console? It sounds like the emoji images are pointing to the wrong place.

  • Global Moderator Plugin & Theme Dev

    @majr it looks like you aren't on the latest version of the plugins. Try this:

    npm install nodebb-plugin-emoji@latest nodebb-plugin-emoji-android@latest
    ./nodebb stop
    ./nodebb activate emoji
    ./nodebb activate emoji-android
    ./nodebb build
    ./nodebb start
    

    You should not see the require a peer of nodebb-plugin-emoji@^2.0.0 warning or the ambiguous inner begin warning. Regardless, these are warnings that you can usually ignore. They're meant for plugin devs, not for users. Also in the future, please share the whole error, not one randomly cut off.

    Then Build Emoji Assets from the plugin page, wait 30sec, and do this:

    ./nodebb stop
    ./nodebb build
    ./nodebb start
    
  • Community Rep

    @pitaj

    Yea a ton of errors

    FetchEvent.respondWith received an error: TypeError: Not allowed to request resource
    

    Also web socket wss: connection failures too all resolving to the plugin folders and/or emojis folders/resrouces.

  • Global Moderator Plugin & Theme Dev

    @omega can you share more information? Like a screenshot of your console showing all of the errors?

    Or even give me a link to your site so I can investigate.

  • Community Rep

    @pitaj Solved!

    You think I would have configured this right... the refresh was the clue... I forgot to set the http to https in the config.json file... thanks for pointer to look in the browser console! It was easier to observe the flip from http to https when refreshing. šŸ˜²


  • @pitaj

    Hello, thank you for all your help but it made no difference. I did it exactly as you explained.

    I have one error in the console of the browser. Transplated in English
    the android plugin says:
    "Failed to load resource: The request timed out". That would be a little bit strange.

    I wonder why. Is my server too slow to show emojis? I am using nginx.

  • Global Moderator Plugin & Theme Dev

    @majr please provide the full error. Include what resource it says timed out.

    Do you have any errors in the server log?

    Is your site public? I'd like to see what's going on.

Suggested Topics

| |