Permition for Cross domain access

Technical Support

Suggested Topics

  • 0 Votes
    3 Posts


    I don't really know, if this will help you, but:

    Bildschirmfoto 2021-04-19 um 15.13.41.png

    If you change e.g sorting inside recent-Page from All Topics to New Topics the page refreshes and the URL turns from


    Once the page reloads, your hook filter:topics.get should be fired again. But in this case, with the filtering changed via dropdown. You have the get parameter ?filter=new to work with serverside.

    Maybe this is an option for you. You can use your template in combination with javascript to trigger an .change() or .click() -Event on your custom dropdown menu.

    Here is a little snippet.

    $(window).on('action:ajaxify.end', function(data) { let currentUrl = $(location).attr('href'); $('div#content').prepend('<a href="#" id="reloadTrigger">This is a example</a>'); $('a#reloadTrigger').click(function(){ window.location.href = currentUrl + "?filter=true"; }) });

    This prepends a a-Element before content-Div:

    Bildschirmfoto 2021-04-19 um 15.27.38.png

    Once you click on This is a example the url turns from to

    And your hook filter:topics.get should be fired again. Now you could work with the GET-Parameter filter=true.

    Hope this helps and inspired you. 🙂


  • 1 Votes
    3 Posts

    @jonaski said in Empty captcha in login page, cant access admin settings:


    Looks like there was an issue in the plugin with the login page. Should be fixed in 0.7.7. Let me know if it works now.

  • 0 Votes
    3 Posts

    You could also just make a new location block that points to to .well-known location on your disk.

    I have my main forums ( under /var/www/nodebb/forums, and then have the under /var/www/.well-known

  • 0 Votes
    6 Posts


    Thanks mate...

    I had a bit of a play with it.... Works as advertised... Great plugin.

    I'd love the ability to share a copy of the assets folder somehow as well tho. But I know this wouldn't be very safe.

  • Domain Not Updating

    Technical Support
    0 Votes
    9 Posts

    Issue is solved, seemed to be a wrongly set Allowed-from setting under Settings->Advanced->Headers