Failed to load emoji metadata 1.13.3

Technical Support
  • @Staff I'm facing this weird issue. Exactly same as below

    The problem is that after upgrade from 1.12.2 to 1.13.3 I can't access /admin/plugins/emoji, it returns 404.

    Removing the plugin and installing again doesn't fix it.

    PS. I've all emoji relate plugins disabled.

    Any ideas?

  • You have tried rebuilding and restarting NodeBB?

  • @PitaJ Yes, I have rebuilt after uninstalling the plugin and again after activating. 404 doesn't go away. I also tried to install the plugin through NPM too but in vein.

  • are there any errors when building or starting nodebb?

  • @PitaJ No build errors. Errors on start

    2020-05-21T10:35:13.627Z [4567/12595] - info: [build] Building in parallel mode
    2020-05-21T10:35:13.628Z [4567/12595] - info: [build]         plugin static dirs  build started
    2020-05-21T10:35:13.631Z [4567/12595] - info: [build]          requirejs modules  build started
    2020-05-21T10:35:13.632Z [4567/12595] - info: [build]           client js bundle  build started
    2020-05-21T10:35:13.636Z [4567/12595] - info: [build]            admin js bundle  build started
    2020-05-21T10:35:13.637Z [4567/12595] - info: [build]         client side styles  build started
    2020-05-21T10:35:13.637Z [4567/12595] - info: [build] admin control panel styles  build started
    2020-05-21T10:35:13.637Z [4567/12595] - info: [build]                  templates  build started
    2020-05-21T10:35:13.638Z [4567/12595] - info: [build]                  languages  build started
    2020-05-21T10:35:13.638Z [4567/12595] - info: [build]                     sounds  build started
    2020-05-21T10:35:14.051Z [4567/12595] - info: [build]                     sounds  build completed in 0.413sec
    2020-05-21T10:35:14.250Z [4567/12595] - info: [build]         plugin static dirs  build completed in 0.621sec
    2020-05-21T10:35:21.661Z [4567/12595] - info: [build]           client js bundle  build completed in 8.029sec
    2020-05-21T10:35:22.436Z [4567/12595] - info: [build]          requirejs modules  build completed in 8.805sec
    2020-05-21T10:35:26.681Z [4567/12595] - info: [build]         client side styles  build completed in 13.043sec
    2020-05-21T10:35:26.782Z [4567/12595] - info: [build]            admin js bundle  build completed in 13.146sec
    2020-05-21T10:35:26.935Z [4567/12595] - info: [build] admin control panel styles  build completed in 13.298sec
    2020-05-21T10:35:29.294Z [4567/12595] - info: [build]                  languages  build completed in 15.656sec
    2020-05-21T10:35:33.710Z [4567/12595] - info: [build]                  templates  build completed in 20.073sec
    2020-05-21T10:35:33.712Z [4567/12595] - info: [build] Asset compilation successful. Completed in 20.084sec.
    2020-05-21T10:36:51.830Z [4567/13262] - error: /var/www/community/nodebb-plugin-emoji/node_modules/fs-extra/lib/mkdirs/make-dir.js:86
          } catch {
    SyntaxError: Unexpected token {
        at createScript (vm.js:80:10)
        at Object.runInThisContext (vm.js:139:10)
        at Module._compile (module.js:616:28)
        at Object.Module._extensions..js (module.js:663:10)
        at Module.load (module.js:565:32)
        at tryModuleLoad (module.js:505:12)
        at Function.Module._load (module.js:497:3)
        at Module.require (module.js:596:17)
        at require (internal/module.js:11:18)
  • @fais3000 said in Failed to load emoji metadata 1.13.3:


    Found out that [email protected] is loading
    │ ├─┬ [email protected]

    Which is causing the error.


  • Upgrade to Node.js 10

  • @PitaJ Updating to node 10 fixed the issue. Thanks

Suggested Topics

  • 1 Votes
    23 Posts

    I made it!

    Upgraded from nodebb v1.17 on Ubuntu 18.04 with mongodb 4.0 to nodebb v3.2.1 on Ubuntu 20.04 with mongodb 5.0. Used node v18 to update nodebb.

    Had a few minor issues (getting rid of an expired mongodb 4.0 key), thinking of using npm install --global npm@6 to avoid any issue with plugins updates (emoiji, markdown).

    And voilà!

    Thanks for all the work, the new admin dashboard is sexy as hell.
    Keep up the good work and enjoy your summer!

    Happy GIF

  • Upgrading from 1.19.5

    Unsolved Technical Support
    0 Votes
    9 Posts

    Ah yes, it seems I overlooked that when I deactivated all the plugins and only reactivated the persona theme.

    Seems to be working to a fashion, just need to get some plugins I rely on updated.

  • 0 Votes
    7 Posts

    It looks to have fixed after a freshly re run of mongorestore.

    Thanks for the support!!

  • 1 Votes
    4 Posts

    Fixed in the package manager, your plugin lists should be working again.

  • 0 Votes
    4 Posts

    I've already tried to go straight from 0.7.3 -> 0.9.0 with success. Plugin support hasn't caught up yet though.

    @pichalite , I'm using a 2nd instance of nodebb, with a 2nd mongodb instance. I first upgraded my plugins to the latest, ran ./nodebb upgrade while on 0.7.3

    I then:
    git checkout v0.8.x
    git pull (just in case)
    ./nodebb upgrade

    running in dev mode just crashes and relaunches when hitting the categories page. When I first installed the forum, I was using v0.8.0 and switched to v.7.x since the plugin support wasn't updated yet.

    I am using the Vanilla theme and it upgraded to 4.0.8 after switching to v0.8.2