createUser "Modal" in ACP



  • Ran into a"unknown" with the createUser modal for "New User" in the admin CP. The modal is instant closing and I cannot for the life of my locate the root cause.

    For the sake of troubleshooting, I removed all plugins to eliminate compatibility issues with the recent update and the issue persists. I went to my backups of the last node version and no issue.

    Do not see any errors in the logs.


  • Global Moderator

    The last NodeBB version worked fine? Which exact versions are you talking about?

    Have you looked for errors client or server side?



  • So you try to manually add a new user but the dialog for that disappears after a second ? If so, than I have the very same problem. Also log out and register a new account does not work, as the final submit button does nothing ..



  • Manual registration works again by doing:

    npm install textcomplete

    However to add users from the ACP is still broken, as the dialog for that disappears after a second. No errors in the logs shows.



  • To answer @PitaJ Currently running NodeBBv1.13.1.

    @0xA4B16 Noticed the same after your comment. I am noticing site connectivity issues from certain users. Going to change a datacenter location and fresh install and attempt to recreate.



  • Made a fresh and clean nodebBB installation on a mini VPS, and with v1.12.2 all works, normal user registration, or ACP user creation works. With 1.13.1 there seems to be something wrong as it worked like 1-2 weeks ago or so.


  • Admin Staff

    I can reproduce the issue with the create user modal closing immediately on this forum. I will take a look.


  • Admin Staff

    The new user modal is fixed in this commit.



  • Still the same, I tried:

    git pull
    ./nodebb upgrade

    and also

    git fetch
    git reset --hard origin/v1.13.x
    ./nodebb upgrade

    both times, the ACP user bug is the same .. 🐀


  • Admin Staff

    The fix is only on the master branch.


Log in to reply
 

Suggested Topics

| |