NodeBB on cPanel with Root

Technical Support

Suggested Topics

  • 0 Votes
    1 Posts

    I am trying to configure NodeBB on a site with /forum URI of the site serving NodeBB. Here is my configuration:

    Protocols h2 http/1.1 ProxyRequests off <Location /forum> RequestHeader set X-Forwarded-Proto "http" ProxyPreserveHost On ProxyPass http://localhost:4567 ProxyPassReverse http://localhost:4567 RewriteCond %{REQUEST_URI} ^/ [NC] RewriteCond %{QUERY_STRING} transport=websocket [NC] RewriteRule /(.*) ws://localhost:4567/$1 [P,L] </Location>

    However, NodeBB does not load completely. I am unable to load other assets of NodeBB. Can someone help out with this?

  • 0 Votes
    2 Posts

    @h7 tried on a different Debian 7 (Wheezy) server, to make sure this is a common issue:

    Node.js v4.2.2 Redis server v=3.2.11 NodeBB v1.0.3

    NodeBB installs again, without errors but the log comes back with the exact same [2458] - error: undefined

    npm rm nodebb-plugin-emoji-one npm install [email protected]

    fixed that error, now:

    info: Time: Sun Oct 08 2017 04:59:32 GMT+0300 (MSK) info: Initializing NodeBB v1.0.3 [outdated] nodebb-plugin-emoji-one installed v1.1.4, package.json requires 1.1.0 warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them: warn: ./nodebb upgrade [cluster] Child Process (6503) has exited (code: 0, signal: null)

    OK, removing the plugin npm rm nodebb-plugin-emoji-one and ./nodebb start worked, NodeBB v1.0.3 running, still can't log-in:

    warn: [meta/dependencies] Bundled plugin nodebb-plugin-emoji-one not found, skipping dependency check. [minifier] file not found, node_modules/ [minifier] file not found, node_modules/ info: NodeBB Ready info: Enabling 'trust proxy' info: NodeBB is now listening on: error: /login invalid csrf token error: /login invalid csrf token

    using older versions of

    npm remove npm remove npm install [email protected] npm install [email protected]

    did the trick, NodeBB v1.0.3 running and ready for myBB to NodeBB transition

  • 0 Votes
    6 Posts

    Thank you hek.

    Problem here is to serve Wordpress and NodeBB using proxy and not a problem with firewall.

  • 0 Votes
    7 Posts

    @ZenOokami said:

    I don't think it was Mongodb's user or db being the issue ._.
    Pretty sure "host identifier" has something to do with either nodebb or mongo's hosting setup, but I think it was that of NodeBB

    on the second time it wasn't accepting my webInstaller settings - not through the command line.

    But thanks.

    I wasn't talking about host identifier, I was talking about how to set up using auth and managing your DB's.

    You having connection issues you should post all your logs, including nodebb, nginx configurations etc.

    You said:

    double colon in host identifier

    Most likely issue with having a wrong syntax with the config.

  • Can't restore nodebb

    Technical Support
    0 Votes
    9 Posts

    I fixed it using

    and setting to todays date, so now it says "Schema is up-to-date" and all works perfectly.

    I hope its ok now? xD