1.11.0 Breaking Changes


  • GNU/Linux Admin

    Theme changes required:

    NodeBB/NodeBB#6849 / NodeBB/NodeBB#6841


  • Staff Admin

    action:group.destroy replaced with action:groups.destroy.

    plugins.fireHook('action:groups.destroy', { groups: groupsData });


  • Staff Admin

    /user/__self__/* removed please use /me/* For example to have a link in the nav bar to the users bookmarks use `/me/bookmarks/ as the navigation route.


  • Gamers

    Hi guys. What do I need to upgrade my NodeJS to before upgrading NodeBB? Sorry, kind of a noob.


  • Global Moderator

    @Michael-Pfaff you need at least Node 8, but I recommend Node 10, as it's the latest LTS


  • Gamers

    @PitaJ said in 1.11.0 Breaking Changes:

    @Michael-Pfaff you need at least Node 8, but I recommend Node 10, as it's the latest LTS

    Great, thanks. I feel like last time I upgraded Node it broke NodeBB, so it's been a while. I'll upgrade to 10.



  • Sorry for post here. We have a lot of plugins that now are breaked in v1.11.0. Because plugins authors delay to fix them, can help me to do a dirty fix to these? I knows JS and nodeJS. But no knows internals of NodeBB plugins architecture. These are the errors

    2018-12-04T07:23:19.503Z [8888] - warn: [plugins/require] Cannot find module './topics', please update your plugin!
    2018-12-04T07:23:19.503Z [8889] - warn: [plugins/require] Cannot find module './topics', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:7:29
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:7:29
    2018-12-04T07:23:19.503Z [8889] - warn: [plugins/require] Cannot find module './user', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:8:25
    2018-12-04T07:23:19.504Z [8888] - warn: [plugins/require] Cannot find module './user', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:8:25
    2018-12-04T07:23:19.589Z [8889] - warn: [plugins/require] Cannot find module './settings', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:9:32
    2018-12-04T07:23:19.589Z [8889] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:10:29
    2018-12-04T07:23:19.590Z [8889] - warn: [plugins/require] Cannot find module './socket.io/admin', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:11:35
    2018-12-04T07:23:19.598Z [8888] - warn: [plugins/require] Cannot find module './settings', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:9:32
    2018-12-04T07:23:19.598Z [8888] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:10:29
    2018-12-04T07:23:19.599Z [8888] - warn: [plugins/require] Cannot find module './socket.io/admin', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:11:35
    2018-12-04T07:23:19.621Z [8888] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
    2018-12-04T07:23:19.621Z [8889] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at Object.<anonymous> (/opt/vapor/nodebb/node_modules/nodebb-plugin-iframely/library.js:11:31)
        at Object.<anonymous> (/opt/vapor/nodebb/node_modules/nodebb-plugin-iframely/library.js:11:31)
    
    2018-12-04T07:23:20.177Z [8888] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-theme-va
    
    2018-12-04T07:23:20.232Z [8888] - warn: [plugins/require] Cannot find module './database', please update your plugin!
        at Object.YoutubeLite.init [as method] (/opt/vapor/nodebb/node_modules/nodebb-plugin-youtube-embed/library.js:20:22)
    2018-12-04T07:23:20.232Z [8889] - warn: [plugins/require] Cannot find module './database', please update your plugin!
        at Object.YoutubeLite.init [as method] (/opt/vapor/nodebb/node_modules/nodebb-plugin-youtube-embed/library.js:20:22)
    

    Thank you so much. Really we need these plugins.


  • Staff Admin

    Those are just warnings the plugins should still work, I am sending PRs to those plugins to fix the warnings.


  • Gamers

    @baris thabks alot , we r waiting for new version of node bb with plugins compatibility before we di update coz we r using many plugins which might break.

    @fais3000


  • Global Moderator

    @faizanzahid the current version of NodeBB still has compatibility with those plugins. Future version will not.


Log in to reply
 

Suggested Topics

| |