Update, "NodeBB could not be restarted, as a running instance could not be found." error



  • Tried to update my site to 1.10.2. Don't think I followed the steps correctly. When I try to start and restart Nodebb as it is right now I get NodeBB could not be restarted, as a running instance could not be found.

    On the update part when I run git merge origin/v1.10.x I get :

    error: The following untracked working tree files would be overwritten by merge:
    	public/language/lv/admin/admin.json
    	public/language/lv/admin/advanced/cache.json
            ... and so on 
    

    Thankyou for any help.


  • Global Moderator

    What guide are you following?



  • @PitaJ The official documentation link from the admin box noticing me to update. https://docs.nodebb.org/configuring/upgrade/



  • @PitaJ Running ./nodebb dev I get:
    error: Your NodeBB schema is out-of-date. Please run the following command to bring your dataset up to spec:

    And when I click the upgrade command I get this error on step 4:

    TypeError: topics.updateLastPostTimeFromLastPid is not a function
        at /home/admin/web/mywebsite/public_html/src/upgrades/1.10.2/fix_category_topic_zsets.js:31:14
        at nextTask (/home/admin/web/mywebsite/public_html/node_modules/async/dist/async.js:5324:14)
        at Immediate.next (/home/admin/web/mywebsite/public_html/node_modules/async/dist/async.js:5331:9)
        at Immediate._onImmediate (/home/admin/web/mywebsite/public_html/node_modules/async/dist/async.js:969:16)
        at runCallback (timers.js:810:20)
        at tryOnImmediate (timers.js:768:5)
        at processImmediate [as _immediateCallback] (timers.js:745:5)
    


  • @ckubs The error "The following untracked working tree files would be overwritten by merge:" indicates that between the time that you last upgraded, and now, you have made some changes to the files in that list, and so the git command will not complete and you are not being upgraded. Have you been making changes to the Latvian translations? The best way to do that is through the Transifex localisation tool, and not by changing the public/language/lv files directly.

    The easiest fix for you, if you are happy to lose your changes, is to simply delete all the files that the error is complaining about. If it's only the Latvian files, then you can do 'rm -rf public/language/lv' and they will be gone.

    Alternatively, you can keep the Latvian files in another directory by doing 'mv public/language/lv public/language/my-lv'.

    Once the files are no longer in existence, after you do one of the previous steps or something similar, retry the upgrade procedure!

    Pēteris no Dublinas



  • @PKRoma I'm not latvian. Nor did I changed any other file from the Nodebb error message. In the mean time just deleted latvian language and the rest of the files from that list and I could upgrade.



  • @ckubs Excellent, I'm glad that went well!


Log in to reply
 

Suggested Topics

  • 1
  • 10
  • 25
  • 2
  • 2
| |