Installation on Digital Ocean Droplet Issue



  • Hi I'm using this guide for installing nodeBB on a digital ocean Ubuntu Droplet:

    The process works great except I'm having trouble at the "npm install" and "node app --setup" parts.

    After I do "npm install" I get the following warnings:

    bill@ktm-husq-250-300-more-nodebb-nginx-ubuntu-forum-01:/var/www/nodebb/forums$ npm install
    npm WARN enoent ENOENT: no such file or directory, open '/var/www/nodebb
    /forums/package.json'
    npm WARN forums No description
    npm WARN forums No repository field.
    npm WARN forums No README data
    npm WARN forums No license field.

    So I figure it's just a random warning but then I do "node app --setup" and get the following errors:

    bill@ktm-husq-250-300-more-nodebb-nginx-ubuntu-forum-01:/var/www/nodebb/forums$ node app --setup
    module.js:328
    throw err;
    ^

    Error: Cannot find module 'nconf'
    at Function.Module._resolveFilename (module.js:326:15)
    at Function.Module._load (module.js:277:25)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/var/www/nodebb/forums/app.js:28:13)
    at Module._compile (module.js:410:26)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Function.Module.runMain (module.js:442:10)

    I tried this guide twice so far and I run into issues in the same place. Any ideas?

    Thanks!


  • Global Moderator

    You do realize that guide is from 2015 right? I suggest you try https://docs.nodebb.org/installing/os/ubuntu/



  • @PitaJ Hey thanks for the reply!

    I did notice shortly after posting that the guide was old and focused on ubuntu 14.04. I found another guide but it was also old.

    The guide you linked is what I need, however, I'm not sure how to do it correctly as the other guides were mostly copy/paste.

    I guess I'm not technically inclined enough to make the commands listed in the guide work on my digital ocean via root ssh.

    For instance once logging in and pasting the following command(s) to just install node.js:

    $ curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
    $ sudo apt-get install -y nodejs

    It simply says command not found. That's just step 1 also hehe. Is there any assistance or recommendations for setting it up on dOcean droplet?



  • Never mind I was accidentally using the $ sign LOL. Was a long night.


 

Suggested Topics

  • 5
  • 4
  • 3
  • 4
  • 1
| |