warning about npm v5.7.0

General Discussion
  • #1

    https://github.com/npm/npm/issues/19883

    There is a bug that breaks the OS if you use npm (5.7.0)with sudo. Be forewarned!

    So when can NodeBB switch to yarn 😄

  • GNU/Linux
    #2

    Heh I've been following that 5.7.0 stuff as it happened. Fun stuff.

    Thanks for the warning! Fortunately the danger has passed, npm released v5.7.1

    I'm not a big fan of npm, even though our entire plugin ecosystem relies on it. If yarn were to start their own ecosystem (yarn publish!!), I would switch over immediately.

    Anyhow. You can use yarn with NodeBB if you'd like. Thanks to @pitaj, you can specify "package_manager": "yarn" in config.json and the ./nodebb commands will default to yarn.

  • #3

    @julian Hmm, maybe I will make a swap over to Yarn. Not sure if it is worth the effort though...

  • GNU/Linux
    #4

    From a development standpoint it is superior. Yarn works great with linked modules, and is backed by a fantastic team (with corporate backing from some major players as well).

    npm tends to clobber all of my linked modules sigh.


Suggested Topics


| | | |