Less eager emoji autocompletion

  • Hi!

    In French typography, the rule is to put a space before colons (we write « les suivantes : » instead of "following:”). Sadly, having a space before a colon will trigger emoji autocompletion.

    This is really annoying because we keep writing 💯 everywhere and having to delete it afterward. The key combination is “space”, “colon”, “enter” because you usually put colons before a quotation or a list…

    With emoji-extended, there was a panel to set the regex. I'm not sure if that's really useful. Maybe just a 2-5 seconds timer before showing the autocompletion box would be welcome. Or maybe don't insert any emoji if enter is pressed while not having interacted with the autocompletion box in any way. Or just an option in ACP to disable autocompletion…

    I had to disable the emoji plugin entirely for now.

    Thanks for any help!

    ping @PitaJ

  • Global Moderator

    A delay is definitely not going to happen, that sounds infuriating for anyone who actually wants the emoji to show up.

    My solution will be to make it so the emoji completion will not show up until a letter is typed. For instance, : won't trigger it, but :a will. That will make spaces not trigger it either. That'll also help prevent it from showing up while writing code.

    I've create an issue: https://github.com/NodeBB/nodebb-plugin-emoji/issues/12



Looks like your connection to NodeBB was lost, please wait while we try to reconnect.