Unable to post new topics or reply to existing ones



  • Versions etc:
    NodeJS - 6.11.1
    NodeBB - 1.5.2
    NPM - 5.3.0
    Redis - 4.0.0
    CentOS - 6.9

    I seem to have a problem with the composer-default plugin. I cannot create or reply to posts.

    NodeBB logs show the following warning:

    "[plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crash$

    • nodebb-plugin-composer-default"

    When I click "New Topic", I see the following error in the console:

    "nodebb.min.js:1 Uncaught TypeError: Cannot read property 'length' of null
    at HTMLDocument.<anonymous> (nodebb.min.js:1)
    at l (nodebb.min.js:1)
    at u (nodebb.min.js:1)"

    Any idea what the problem is? I've tried reloading / restarting / building NodeBB without success.


  • Global Moderator

    That's not your NodeBB version, that's your Node.js version. What is your NodeBB version?



  • @pitaj Sorry yes, was on autopilot.

    NodeBB version is 1.5.2, have edited the original OP for clarity.


  • Global Moderator

    What version is nodebb-plugin-composer-default?

    Try these things:

    • npm install
    • ./nodebb build
    • Try resetting extra plugins


  • Composer version is 5.0.2.

    No change unfortunately after those steps. Once I'd reset plugins I just re-enabled composer to test but the same issue persists.



  • Still battling with this issue. Seems likely it's to do with the version mismatch for composer vs NodeBB, as advised in the logs.

    Not really sure why there would be a version mismatch on a plugin which (as far as I know) is bundled with the NodeBB install. If it is the wrong version I'm not sure which is the right one either.


  • Global Moderator

    @btc What branch of the git repository are you on? git status should say "On branch [branch name]". Try running git pull, then ./nodebb upgrade and restart.



  • @pitaj Sorry for the delay, I wasn't getting reply notifications.

    I'm on the master branch of the git repository.

    Git pull gives an error: "error: Your local changes to 'package.json' would be overwritten by merge. Aborting."

    I haven't made any changes to that file.

    The issue still exists following ./nodebb upgrade.


  • Global Moderator

    @btc npm install --save modifies package.json, so that's probably what changed it. Run git reset --hard origin/master to both reset package.json and to pull the latest changes on the master branch.



  • Thanks so much, that has worked and I can now post new topics and replies.

    However I now have another issue but I think it's unrelated so will start a new thread.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.