Error when upgrading from 1.4.5 to 1.5.0



  • Hello,

    I'm trying to upgrade from 1.4.5 to 1.5.0 and getting the following error:

    Error: Cannot find module './_stream_duplex'

    Any idea ?

    Error detail and steps are:

    nodebb@host:~$ git fetch
    remote: Counting objects: 4078, done.
    remote: Compressing objects: 100% (32/32), done.
    remote: Total 4078 (delta 2474), reused 2465 (delta 2465), pack-reused 1581
    Receiving objects: 100% (4078/4078), 921.69 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (3284/3284), completed with 1006 local objects.
    From https://github.com/NodeBB/NodeBB >
    d19e59f..fb2f857 v1.x.x -> origin/v1.x.x

    • [new branch] acp-search-escape -> origin/acp-search-escape
    • [new branch] auto-lang -> origin/auto-lang
    • [new branch] ban-improvements -> origin/ban-improvements
    • [new branch] build-ref -> origin/build-ref
    • [new branch] build-refactor -> origin/build-refactor
      e4168f4..3a1eba2 develop -> origin/develop
    • [new branch] filter-unread-hook -> origin/filter-unread-hook
    • [new branch] fix-5536 -> origin/fix-5536
    • [new branch] fix-5622 -> origin/fix-5622
    • [new branch] fix-5631 -> origin/fix-5631
    • [new branch] fix-signatures -> origin/fix-signatures
    • [new branch] import-export-cleanup -> origin/import-export-cleanup
    • [new branch] julianlam-patch-1 -> origin/julianlam-patch-1
      7f713ee..11fc790 master -> origin/master
    • [new branch] notif-abort -> origin/notif-abort
    • [new branch] patch-pitaj -> origin/patch-pitaj
    • [new branch] reject-nonaudio-uploads -> origin/reject-nonaudio-uploads
    • [new branch] sounds-fix -> origin/sounds-fix
    • [new branch] upgrade-progress-bar -> origin/upgrade-progress-bar
    • [new branch] utils-rtrim -> origin/utils-rtrim
    • [new branch] v1.5.x -> origin/v1.5.x
    • [new tag] v1.4.6 -> v1.4.6
    • [new tag] v1.5.0 -> v1.5.0

    nodebb@host:~$ git checkout v1.5.x
    Branch v1.5.x set up to track remote branch v1.5.x from origin.
    Switched to a new branch 'v1.5.x'
    nodebb@host:~$ ./nodebb upgrade

    1. Bringing base dependencies up to date... OK
    2. Checking installed plugins for updates... module.js:327

    throw err;

    ^

    Error: Cannot find module './_stream_duplex'

    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at BufferList.Readable (/var/www/regards.photo/node_modules/request/node_modules/bl/node_modules/readable-stream/lib/_stream_readable.js:128:22)
    at BufferList.Duplex (/var/www/regards.photo/node_modules/request/node_modules/bl/node_modules/readable-stream/lib/_stream_duplex.js:43:12)
    at new BufferList (/var/www/regards.photo/node_modules/request/node_modules/bl/bl.js:32:16)
    at BufferList (/var/www/regards.photo/node_modules/request/node_modules/bl/bl.js:7:12)
    at Request.readResponseBody (/var/www/regards.photo/node_modules/request/request.js:1015:16)
    at Request.onRequestResponse (/var/www/regards.photo/node_modules/request/request.js:996:12)


  • Global Moderator

    Try deleting node_modules/request and re-running npm install


  • Admin

    Yeah I am really not sure why it throws that error and why ./nodebb upgrade doesn't handle it.

    In any case, as @pitaj says, uninstall request (npm unl request also works), and re-install.



  • @julian @PitaJ Thank you. The module wasn't installed at all (dunnow how it was working before). So nmp install request fixed the issue :)

    NB: Don't know if it's normal, but It was the longest upgrade ever (More than 2h for a 400Mb DB).


  • Admin

    Yes, 1.4.x to 1.5.x was a bit of a jump and there were lots of upgrade scripts that touched post hashes :smile:


  • Gamers

    @azeus I'm also about to upgrade from 1.4.4. to 1.5.0. What steps did you take to install? I'm kind of nervous!



  • @Michael-Pfaff said in Error when upgrading from 1.4.5 to 1.5.0:

    @azeus I'm also about to upgrade from 1.4.4. to 1.5.0. What steps did you take to install? I'm kind of nervous!

    Like usual

    $ cd /nodebb_Home
    $ git fetch
    $ git checkout v1.5.x
    $ ./nodebb upgrade

    And of course backup before ;)


  • Gamers

    @azeus said in Error when upgrading from 1.4.5 to 1.5.0:

    @Michael-Pfaff said in Error when upgrading from 1.4.5 to 1.5.0:

    @azeus I'm also about to upgrade from 1.4.4. to 1.5.0. What steps did you take to install? I'm kind of nervous!

    Like usual

    $ cd /nodebb_Home
    $ git fetch
    $ git checkout v1.5.x
    $ ./nodebb upgrade

    And of course backup before ;)

    Worked perfectly! Thank you!


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.