V1.0.0 login trigger error 403 forbidden



  • ./nodebb log print out: invalid csrf token

    clear cookie not working, register also trigger same issues.

    I tried with latest version it works fine.

    I need the v1.0.0 because I need to use it with this plugin https://github.com/akhoury/nodebb-plugin-import

    Currently stucked and no work around. Please help, thanks!



  • Hi there,

    I have the same problem.... latest version of NodeBB works great but I need v1.0.0 because of Xenforo convertor plugin... Can someone help us to solve this "Forbidden" situation?

    I want to migrate huge forum from Xenforo to NodeBB but a week or more I'm stuck wit this Forbidden shit...



  • Last night i try to install v1.4.5 create admin account, disable all plugins and themes, install xenforo-import-plugin, activate it.. then stop nodebb, downgrade from 1.4.5 to 1.3.0 to 1.2.0 and finale to 1.0.0

    Start NodeBB from server i was able to login and go to admin panel, configure xenforo plugin but nothing happens at this stage, when press "convert" nothing happen.

    It would be such great time if someone would upgrade this plugin so we can migrate from Xenforo to NodeBB.

    I think, that this story about NodeBB is great and i like it much more then Xenforo, i use xenforo about 2.5 years (paid licence).



  • 5 days... Anyone?


  • Plugin & Theme Dev

    @vlada start with setting up NodeBB v1.0.0, install the import plugin, finish the import and then upgrade NodeBB to latest.



  • Hi, @pichalite sorry for late respond...

    When i do like that i got same error like author of this Topic.

    ***./nodebb log print out: invalid csrf token

    clear cookie not working, register also trigger same issues.

    I tried with latest version it works fine.***



  • Real shame that nobody care about migration tools.


  • Community Rep

    @vlada Just to double check, are you starting with a completely clean install when you install NBB v.1.0.0? Really weird things happen (or just simply will not work) if you're downgrading the way you were.

    Make sure you:

    • start on a completely clean directory
    • start with a completely clean database.

    For all we know, you could be trying to run a v1.0.0 forum on a database that has a schema expecting v1.4.5.

    We could also be more helpful if you provide more info like

    • what system you're on
    • what DB you're using and version
    • The exact steps you're taking.

    btw you should use NodeBB v1.0.3 like the plugin tells you to, but if you must use the version of nodebb-plugin-import that only supports NBB v1.0.0, make sure you're actually using the right version



  • Hello,

    This is the solution that worked for me 👍 and no more problem with csrf message.

    ln -s /opt/nodebb/node_modules/socket.io-client/dist/socket.io.js /opt/nodebb/node_modules/socket.io-client/socket.io.js

    But you will probably have the same problem in the next step


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.