nodebb crashes with node 4,5,6 while listing plugins

Technical Support
  • Hi there,

    I got a nodebb v.1.1.2 running on node v.0.10.43 and everything is fine that far.

    But for nodebb-plugin-calender I need node v4+, so I switched my environment.
    NodeBB starts fine now but as soon as I click on the Plugin page on my admin panel nodeBB crashes and shows me this:

    TypeError: Cannot assign to read only property 'id' of <
        at Object.Plugins.normalise (/home/spicewiesel/bin/nodebb/src/plugins.js:266:20)
        at Request._callback (/home/spicewiesel/bin/nodebb/src/plugins.js:257:12)
        at Request.self.callback (/home/spicewiesel/bin/nodebb/node_modules/request/request.js:187:22)
        at emitTwo (events.js:87:13)
        at Request.emit (events.js:172:7)
        at Request.<anonymous> (/home/spicewiesel/bin/nodebb/node_modules/request/request.js:1044:10)
        at emitOne (events.js:77:13)
        at Request.emit (events.js:169:7)
        at IncomingMessage.<anonymous> (/home/spicewiesel/bin/nodebb/node_modules/request/request.js:965:12)
        at emitNone (events.js:72:20)
        at IncomingMessage.emit (events.js:166:7)
        at endReadableNT (_stream_readable.js:913:12)
        at nextTickCallbackWith2Args (node.js:442:9)
        at process._tickCallback (node.js:356:17)

    Everything is fine as soon as I switch back to my old v.10.43 and even a fresh installation with node v4+ leads to the same result.

    What can I do now?


  • @spicewiesel this is most likely a plugin conflict. Try resetting your plugins and activating them one by one.

Suggested Topics

  • Import on nodeBB

    Unsolved Technical Support
    1 Votes
    5 Posts

    @PitaJ How much work do you think would be involved in updating the import plugin to support NodeBB v2.3? I may well be willing to contribute some time and/or money to this if it's feasible.

  • 0 Votes
    7 Posts


    No sorry, that didn't solve. But following worked:

    After importing mybb, upgrade it to v1.16.0 which produces "Error: ENOENT: no such file or directory, open '/nodebb/node_modules/nodebb-plugin-require/plugin.json' " as mentioned above. Back up both database and any image files imported from mybb under public/uploads/files Delete whole nodebb files and database Install original v1.16.0 (git clone -b v1.16.x Remove only the database, then restore database and image files using backups Works well, it doesn't produce any error even after installing quickstart plugin.

    Additionally, doesn't work on v1.16.0.
    It shows following error on Chrome and the page got frozen while loading:
    colorpicker.js:11 Uncaught TypeError: n.ColorPicker is not a function
    at HTMLInputElement.<anonymous> (colorpicker.js:11)
    at Function.each (jquery.js:381)
    at C.fn.init.each (jquery.js:203)
    at Object.n.enable (colorpicker.js:8)
    at o (admin.js:31)
    at Object.i.init (admin.js:9)
    at ajaxify.js:336
    at Object.execCb (require.js:1696)
    at n.check (require.js:883)
    at n.<anonymous> (require.js:1139)

    Anyways, it's not to be discussed here I guess.
    Thank you very much!

  • 2 Votes
    39 Posts

    Can you identify the last commit it works on?

  • 0 Votes
    7 Posts

    To piggyback off of @rod's line of questioning... can you access the forum when you navigate to the ip:port directly?

  • 0 Votes
    5 Posts

    Hi @rbeer thanks for your reply, I tried the command you provided, but its already installed...

    However, what seem to help was making some changes to git due to a timeout issue or proxy issue.

    [url ""]
    insteadOf = [email protected]:
    [url "https://"]
    insteadOf = git://

    Once I done this, it installed properly and now runs.