How to install and setup NodeBB?

Technical Support

Suggested Topics

  • 0 Votes
    12 Posts

    Problem solved. It was the nodebb-plugin-cash who caused the problem.

    After deleting this plugin my NodeBB worked again 🙂

  • 0 Votes
    1 Posts

    I'm trying to install NodeBB using the CentOS documentation for install and am admittedly a noob. Things seem to go well until I get to installing the Development Tools in step 3 (

    I get an error that says Error: Package: intltool-0.41.0-1.1.e16.noarch (base) Requires: perl(XML::Parser).

    However, I'm pretty positive I have the 2.44 version of the Perl XML Parser installed. And, my Perl version is v5.10.1 - any help would be amazing.

    Thanks in advance!


  • 0 Votes
    6 Posts

    ok this worked:

    $ curl -sL | sudo -E bash -
    $ sudo apt-get install -y git nodejs build-essential nginx
    $ sudo apt-key adv --keyserver hkp:// --recv 7F0CEB10
    $ echo 'deb dist 10gen' | sudo tee /etc/apt/sources.list.d/mongodb.list
    $ sudo apt-get update
    $ sudo apt-get install mongodb-org
    $ mongo
    use nodebb
    db.createUser( { user: "nodebb", pwd: "<Enter in a secure password>", roles: [ "readWrite" ] } )
    $ sudo nano /etc/mongodb.conf //uncomment auth = true
    $ sudo service mongodb restart
    $ sudo nano /etc/nginx/conf.d/

    // copy & paste & edit server_name:

    server {
    listen 80;

    server_name; location / { proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header Host $http_host; proxy_set_header X-NginX-Proxy true; proxy_pass http://io_nodes; proxy_redirect off; # Socket.IO Support proxy_http_version 1.1; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; }


    upstream io_nodes {

    // write out

    $ git clone -b v0.9.x nodebb
    $ cd nodebb
    $ npm install --production
    $ npm start

    // finish install from browser: http://server.ip:4567

    $ nano config.json

    // just insert port line

    "url": "http://localhost:4567",
    "port": ["4567", "4568"],
    "secret": "34a78c7d-df06-4d82-9c0b-0a3b528822ec",
    "database": "mongo",
    "port": 4567,
    "mongo": {
    "host": "",
    "port": "27017",
    "username": "nodebb",
    "database": "nodebb"

    // write out

    $ ./nodebb restart

    // now it works without port, on 2 instances

  • 0 Votes
    1 Posts

    Every time I try to access the website I get this error from the ./nodebb log

    { id: 3329,
    msg: 'connection failed, you are banned',
    extra_msg: 'you may retry in 102 seconds\n\r' }
    { [Error: This socket has been ended by the other party] code: 'EPIPE' }

    Does anyone know the solution?

  • 0 Votes
    4 Posts

    Fixed on master thanks for reporting.