Admin panel seems completely broken

Technical Support
  • Hi,

    Upgraded NodeBB today from 0.9.x to 1.x.x. Forum functions appropriately on the frontend, users can create topics and post replies, etc. However, in the admin panel, "Manage Categories" is blank, all the dashboard statistics are blank, and no buttons work. I can't select users. I can't activate or deactivate plugins. I can't even search for them. Themes won't load, skins won't load. Etc.

    I can't find out how to log or debug any of these errors even after dicking around at length with strongloop, node --debug, node --debug-brk. I uninstalled and reinstalled every plugin. I ran upgrades on all the themes I have installed. I did ./nodebb upgrade. Right now I have a half-functional forum that I can't make any meaningful change to, and am regretting upgrading.

    Can anyone give me some direction on what I can do to make logging more verbose than the 8 lines of useless output it spits every time I launch the process?


  • @elandriel ./nodebb log just spits out the last few lines from the log file. You can see the complete log in the log file /path_to_nodebb/logs/output.log

    Also check browser console for any js errors.

  • Thank you. I found it in the console -- it was "Mousetrap" which was enabled in public/src/acp.min.js. I had to comment the entire section out. That was breaking everything else. Appreciate your assistance.

    Edit: Also, FWIW, the output.log only shows the tail of the startup log ending with the plugin spam-be-gone being loaded. Nothing ever posts afterward. Now I can proceed with deactivating plugins singularly and hopefully it was something with one of them which was causing output.log to show basically nothing...

  • @elandriel how are you viewing the contents of the file output.log?

    don't think plugins have the ability to mess with logging in output.log

    edits made to public/src/acp.min.js will be gone once you restart NodeBB.

  • I view it directly with vi as well as watching it realtime in ./nodebb log. The only reason I mention that plugin is because it's the last line of output before it stops logging. However that may be because these errors are not significant enough to warrant a log entry...

    It appears my woes continue anyway as there are issues with the dashboard still not recognizing properties.

    dashboard.js?325979c7-71ca-47a0-89a2-1ae2c285e4c3:190 Uncaught ReferenceError: Chart is not defined
    dashboard.js?325979c7-71ca-47a0-89a2-1ae2c285e4c3:333 Uncaught TypeError: Cannot read property 'segments' of null
    dashboard.js?325979c7-71ca-47a0-89a2-1ae2c285e4c3:49 Uncaught TypeError: Cannot read property 'lt' of undefined

    If .js edits disappear upon a reload then I am going to have a bad time. Any thoughts?

    Thanks again.

  • @elandriel there is no acp.min.js in public/src? do you mean public/acp.min.js?

  • @pichalite what do you see when you run cat logs/output.log from the nodebb directory?

  • You can also get more verbose logging using ./nodebb dev instead of ./nodebb start. This way it will start blocking. Useful for debugging.

  • @frissdiegurke Thanks. I will update more later after I have a bit more down time. I appreciate you guys' help.

    @pichalite The only thing that shows up in output log is the startup stuff, and when I installed a database import plugin with the hopes of exporting my database to a usable format in case I need to blow everything up.

    I did mean /public/acp.min.js; my mistake.

  • This is concerning... due to a change I made in how we load third-party assets.

    @elandriel What happens when you go to these urls?

    • /src/modules/mousetrap.js
    • /src/modules/Chart.js

    They should both load javascript files. If not, something went wrong during startup, as those files should have been bridged.

    During startup in dev mode (./nodebb dev) you'll see a line that looks like this:

    19/4 09:48 [8681] - verbose: [meta/js] 3 of 3 modules bridged

    That line means the bridging was successful and 2 of those three filese are mousetrap and Chart...

  • @julian Thanks for the reply.

    Looking into it, getting http://forum-url/src/mousetrap.js and /src/modules/Chart.js does load javascript files.

    Also, "19/4 11:29 [5447] - verbose: [meta/js] 3 of 3 modules bridged" -- so you have little to fear there. Odd that they are not integrating with my forum post-upgrade.

    The dev console doesn't show me the kind of javascript errors I'm receiving in my browser console so I'm thinking there's possibly something wrong with my install itself. Perhaps a permissions issue or something. So my next step is a total reinstall and mongo reconnect. Will update further after to advise.

  • A full purge and reinstall cleared the issues out. Thank you all for your assistance and my apologies for taking your time.

    FWIW, I absolutely love this forum and product. Great work.

Suggested Topics