Startup error after copying to a different server



  • I'm getting the following error at startup of a nodebb instance which I have just copied from one server to another (all files and mongodb)

    Starting NodeBB
      "./nodebb stop" to stop the NodeBB server
      "./nodebb log" to view server output
      "./nodebb restart" to restart NodeBB
    
    [vagrant@localhost nodebblivecopy]$ ./nodebb log
    
    Type Ctrl-C to exit
    
        at Function.Module._load (module.js:289:25)
    [cluster] Child Process (11015) has exited (code: 0, signal: null)
        at Module.require (module.js:366:17)
        at require (module.js:385:17)
        at module.init (/vagrant/nodebblivecopy/src/database/mongo.js:52:18)
        at /vagrant/nodebblivecopy/node_modules/async/lib/async.js:731:23
        at /vagrant/nodebblivecopy/node_modules/async/lib/async.js:172:37
        at fn (/vagrant/nodebblivecopy/node_modules/async/lib/async.js:717:34)
        at /vagrant/nodebblivecopy/node_modules/async/lib/async.js:1170:16
        at /vagrant/nodebblivecopy/node_modules/async/lib/async.js:172:37
    

    What I already tried:

    npm update
    
    rm -rf ./node_modules
    
    npm install
    
    

    I edited config.json to reflect the change in database name.

    Node version of that particular copy is 0.9. **Upgrading it is not a solution for me ** - I am trying to replicate a specific environment before I test upgrading.



  • @codecowboy How did you copy your files? I do not have experience with Mongodb but take a look at my "dev/test" how to. Possibly it will identify a step you missed.

    https://community.nodebb.org/topic/8479/how-to-create-manage-a-nodebb-test-dev-environment


  • Admin

    That log doesn't show enough... please run with ./nodebb dev for a full in-console log, or look at logs/output.log


  • GNU/Linux

    Node version of that particular copy is 0.9. **Upgrading it is not a solution for me ** - I am trying to replicate a specific environment before I test upgrading.

    "Node" is a bit unspecific.

    If you meant NodeBB 0.9.x see @julian's post above.
    If you instead meant node.js I'm sorry for you because

    NodeBB requires the following software to be installed:

    • A version of Node.js at least 0.10 or greater

    So using NodeBB would not be a solution for you in that case.



  • Sorry. Yes, I meant the NodeBB version. Node version is 4.2.4

    After I deleted node_modules I think what happened is that npm install didnt install mongo or mongo-connect. The error was a bit vague but reinstalling those two packages resolved the problem.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.