Connection to site lost!!!



  • Out of nowhere I get this error

    Things I did,

    Restarted > Server, nodebb, redis

    site's displaying

    Connection to site has been lost, attempting to reconnect.

    here's the link http://in2uk.xyz

    LOGS

     undefined
    11/4 16:51 [21159] - error: /sitemap/pages.xml
     undefined
    11/4 16:51 [21159] - error: /sitemap/pages.xml
     undefined
    11/4 16:51 [21159] - error: /sitemap/categories.xml
     undefined
    11/4 16:56 [21159] - info: [plugins] nodebb-plugin-topic-tags@0.1.1 node_modules/nodebb-plugin-topic-tags
    [cluster] Restarting...
    Clustering enabled: Spinning up 1 process(es).
    11/4 16:56 [21159] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    11/4 16:56 [21159] - info: [app] Database connection closed.
    11/4 16:56 [21159] - info: [app] Web server closed to connections.
    11/4 16:56 [21159] - info: [app] Shutdown complete.
    [cluster] Child Process (21159) has exited (code: 0, signal: null)
    11/4 16:56 [25648] - info: Time: Mon Apr 11 2016 16:56:32 GMT+0200 (CEST)
    11/4 16:56 [25648] - info: Initializing NodeBB v1.0.2
    11/4 16:56 [25648] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-spam-be-gone
    11/4 16:56 [25648] - info: NodeBB Ready
    11/4 16:56 [25648] - info: Enabling 'trust proxy'
    11/4 16:56 [25648] - info: NodeBB is now listening on: 0.0.0.0:4567
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    11/4 16:56 [25648] - info: [plugins/spam-be-gone] Settings loaded
    blacklist returned: undefined
    12/4 00:05 [25648] - error: /webdav/
     invalid csrf token
    12/4 01:56 [25648] - error: /sitemap/topics.1.xml
     undefined
    12/4 01:58 [25648] - error: /sitemap/pages.xml
     undefined
    12/4 02:01 [25648] - error: /sitemap/categories.xml
     undefined
    12/4 02:24 [25648] - error: /sitemap/topics.1.xml
     undefined
    12/4 02:28 [25648] - error: /sitemap/categories.xml
     undefined
    12/4 02:31 [25648] - error: /sitemap/pages.xml
     undefined
    12/4 02:51 [25648] - error: /sitemap/topics.1.xml
     undefined
    12/4 02:58 [25648] - error: /sitemap/pages.xml
     undefined
    12/4 03:00 [25648] - error: /sitemap/categories.xml
     undefined
    12/4 03:24 [25648] - error: /sitemap/topics.1.xml
     undefined
    12/4 03:24 [25648] - error: /sitemap/pages.xml
     undefined
    12/4 03:29 [25648] - error: /sitemap/categories.xml
     undefined
    12/4 03:51 [25648] - error: /sitemap/pages.xml
     undefined
    12/4 03:53 [25648] - error: /sitemap/topics.1.xml
     undefined
    12/4 04:02 [25648] - error: /sitemap/categories.xml
     undefined
    blacklist returned: undefined
    12/4 10:27 [25648] - error: Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
        at errnoException (net.js:901:11)
        at Object.afterConnect [as oncomplete] (net.js:892:19)
    [cluster] Child Process (25648) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...
    [cluster] Child Process (27320) has exited (code: 143, signal: null)
    NodeBB v1.0.2 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    Clustering enabled: Spinning up 1 process(es).
    12/4 10:30 [7168] - info: Time: Tue Apr 12 2016 10:30:32 GMT+0200 (CEST)
    12/4 10:30 [7168] - info: Initializing NodeBB v1.0.2
    12/4 10:30 [7168] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-spam-be-gone
    12/4 10:30 [7168] - info: NodeBB Ready
    12/4 10:30 [7168] - info: Enabling 'trust proxy'
    12/4 10:30 [7168] - info: NodeBB is now listening on: 0.0.0.0:4567
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    12/4 10:31 [7168] - info: [plugins/spam-be-gone] Settings loaded
    12/4 10:36 [7168] - error: Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
        at errnoException (net.js:901:11)
        at Object.afterConnect [as oncomplete] (net.js:892:19)
    [cluster] Child Process (7168) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...
    12/4 10:36 [7256] - info: Time: Tue Apr 12 2016 10:36:26 GMT+0200 (CEST)
    12/4 10:36 [7256] - info: Initializing NodeBB v1.0.2
    12/4 10:36 [7256] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-spam-be-gone
    12/4 10:36 [7256] - info: NodeBB Ready
    12/4 10:36 [7256] - info: Enabling 'trust proxy'
    12/4 10:36 [7256] - info: NodeBB is now listening on: 0.0.0.0:4567
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    12/4 10:36 [7256] - info: [plugins/spam-be-gone] Settings loaded
    12/4 10:41 [7256] - error: Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
        at errnoException (net.js:901:11)
        at Object.afterConnect [as oncomplete] (net.js:892:19)
    [cluster] Child Process (7256) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...
    12/4 10:41 [4753] - info: Time: Tue Apr 12 2016 10:41:50 GMT+0200 (CEST)
    12/4 10:41 [4753] - info: Initializing NodeBB v1.0.2
    12/4 10:41 [4753] - error: Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
        at errnoException (net.js:901:11)
        at Object.afterConnect [as oncomplete] (net.js:892:19)
    [cluster] Child Process (4753) has exited (code: 1, signal: null)
    [cluster] Spinning up another process...
    [cluster] Child Process (4755) has exited (code: 143, signal: null)
    NodeBB v1.0.2 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    Clustering enabled: Spinning up 1 process(es).
    12/4 10:50 [7235] - info: Time: Tue Apr 12 2016 10:50:21 GMT+0200 (CEST)
    12/4 10:50 [7235] - info: Initializing NodeBB v1.0.2
    12/4 10:50 [7235] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-plugin-spam-be-gone
    12/4 10:50 [7235] - info: NodeBB Ready
    12/4 10:50 [7235] - info: Enabling 'trust proxy'
    12/4 10:50 [7235] - info: NodeBB is now listening on: 0.0.0.0:4567
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    12/4 10:50 [7235] - info: [plugins/spam-be-gone] Settings loaded
    LOGS CONTROL PANEL

  • Admin

    12/4 10:41 [4753] - error: Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
    at errnoException (net.js:901:11)
    at Object.afterConnect [as oncomplete] (net.js:892:19)
    

    Looks a like a config problem, is redis running and configured properly.



  • I am not sure its acting strangely. I was not able to create a new topic via browser (PC) the composer didn't even open but via mobile everything works well. I posted a new topic and I can see it after a refresh.
    Let me know if I should type in some commands, I am new to Ubuntu via ssh



  • I did some google and executed this command netstat -npl | grep 6379

    output
    127.0.0.1:6379(port in Red) 0.0.0.0:* LISTEN 8094/redis-server 1


  • GNU/Linux

    Can you post the redis logs please? See https://www.digitalocean.com/community/tutorials/how-to-find-redis-logs-on-ubuntu

    PS: wrap code and logs in ``` please.



  • Error resolved by itself! no worries.

    Thx for the help.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.