Stuck on "Global Moderators group found, skipping creation!"


  • Anime Lovers

    Hello! I want to upgrade our forum to v1.x.x but when I try.... this is what happens.... it just gets stuck on the line "Global Moderators group found, skipping creation!" and no matter how long I leave it there it never skips that, so I'm not able to finish the "nodebb setup" process, anyone has an idea of what am I missing or what could be causing the problem? by the way I'm on MongoDB 3.2.1 and prior to running "nodebb setup" I do first "nodebb upgrade" then "npm update" and then try the setup.

    C:\NodeBB>nodebb setup
    15/3 09:04 [3948] - info: NodeBB v1.0.0 Copyright (C) 2013-2014 NodeBB Inc.
    15/3 09:04 [3948] - info: This program comes with ABSOLUTELY NO WARRANTY.
    15/3 09:04 [3948] - info: This is free software, and you are welcome to redistri
    bute it under certain conditions.
    15/3 09:04 [3948] - info:
    15/3 09:04 [3948] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB!
    
    This looks like a new installation, so you'll have to answer a few questions abo
    ut your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://201.205.239.41:4567)
    Please enter a NodeBB secret (119e12a8-0734-4932-9873-9db09c1a37c1)
    Which database to use (mongo)
    
    15/3 09:06 [3948] - info: Now configuring mongo database:
    Host IP or address of your MongoDB instance (127.0.0.1)
    Host port of your MongoDB instance (27017)
    MongoDB username (nodebb)
    Password of your MongoDB database
    Which database to use (nodebb)
    Configuration Saved OK
    15/3 09:06 [3948] - info: [database] Checking database indices.
    Populating database with default configs, if not already set...
    Previous theme detected, skipping enabling default theme
    Categories OK. Found 8 categories.
    Administrator found, skipping Admin setup
    15/3 09:06 [3948] - info: Global Moderators group found, skipping creation!
    

    Thank you for taking the time!


  • Admin


  • Anime Lovers

    @baris thank you for helping me, well I did the "git checkout v1.x.x" and accordingly to GitExtensions "Already on 'v1.x.x' Your branch is behind 'origin/v1.x.x' by 145 commits, and can be fast-forwarded." so.... I don't get exactly what to do... is it that the fix for this issue is still not on the stable version of the forum? or that I should be moving to a different branch?


  • Admin

    If you are on 1.x.x, do a git pull then try the upgrade again, some fixes are back ported to the 1.x.x branch.


  • Anime Lovers

    @baris well finally managed to get it working, I was missing to accept merging the branch when doing the pull.... but that was not enough as now it was showing me a problem with the widget essentials... so I checkout the commit for "up widget essentials" and that fixed it for me!!

    Thank you for your time @baris 😀 👍




Star

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.