Error While Upgrading v0.9.4 to v1.0.0: ERR value is not a valid float

Solved Technical Support
  • Is it safe to upgrade to 1.0.0 from 0.9.4 now ?

  • @Jenkler In my case, no not yet. There appears to be an issue with the chats in my forum. I am going to delete them from the database (sorry users) and attempt the upgrade again.

    When I finally do this upgrade to production I will send a mass email to my users letting them know that their chat threads will be deleted and give them a little time to make a copy of them if they care about retaining the content.

  • Ok, good to know

    "I am going to delete them from the database" <-- Can you do that from NodeBB ACP ?

  • @Jenkler Unfortunately I cannot.

    I am using redis and the only plugin I found that manages database entries is for Mongodb. I am going to attempt to load the RedditRedis Desktop Manager. @ThingBreaker

  • @pichalite I've made access to my redis database. I see the "messages" that I should delete. Question about that. Should I delete the entire "message:1", "message:2", etc., entries?

    Also, it looks like my first attempt to upgrade created four chat rooms. Should I delete them as well or leave them?

    Thank you.

  • @rod not sure. you can probably delete them if you don't need those back

  • After deleting the "message:x" database keys the upgrade completed without error.

    Upon startup though I am getting an error that is keeping NodeBB from starting:

    $ ./nodebb log
    Type Ctrl-C to exit
    NodeBB v1.0.0 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit:
    Clustering enabled: Spinning up 1 process(es).
    4/3 14:13 [17972] - info: Time: Fri Mar 04 2016 14:13:43 GMT-0700 (MST)
    4/3 14:13 [17972] - info: Initializing NodeBB v1.0.0
    [outdated] nodebb-plugin-soundpack-default installed v0.1.5, package.json requires 0.1.6
    4/3 14:13 [17972] - warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:
    4/3 14:13 [17972] - warn:     ./nodebb upgrade
    [cluster] Child Process (17972) has exited (code: 0, signal: null)

    I ran the upgrade again but still end up with this error upon starting. I do not recall installing the nodebb-plugin-soundpack-default plugin. I believe it is native to NodeBB.

    Help please on what to look at next.

    Thank you.

  • @rod that's an issue reported here

    pull latest v1.x.x and try upgrade again

  • @pichalite I did a git pull and now have a hash of 55b43dca23702dca935aabb953594c8a343ee259

    Ran the upgrade successfully.

    Started NodeBB but had an imgbed plugin errror. I ran the ./nodebb reset -p nodebb-plugin-imgbed command and then attempted the startup. NodeBB started up this time!

    I have upgraded all of my plugins that had available upgrades including the imgbed one. Now on startup it doesn't throw an error. Overall everything is working and I will mark this thread as solved. I won't be upgrading my production to v1.0.0 yet as the Amazon S3 plugin caused NodeBB to crash. I will wait to see if that plugin ever gets updated. @wladiston

    Thank you for your help.

  • Followup. I found a different Amazon S3 uploader plugin that seems to be working under v1.0.0. If interested see here

Suggested Topics

  • NodeBB Upgrade Error

    Solved Technical Support
    0 Votes
    5 Posts

    No, I did not. It worked after I did so. Somehow I missed that obvious section...

  • 0 Votes
    3 Posts

    here was the offending line:

    body { height: 100%; }
  • 1.7.5 to 1.9.0

    Technical Support
    0 Votes
    2 Posts

    Yes it is, you can switch to v1.9.x and run ./nodebb upgrade

  • connection error 503

    Unsolved Technical Support
    0 Votes
    2 Posts

    Ok, i think nobody will answer that question.

    After dig it i realised that the issue is about apache mod_proxy_wstunnel. When nodebb works on TCP port there is no problem but on unix socket it seems that mod_proxy_wstunnel is not meant to work with Unix domain sockets.

    For example;
    ProxyPass "/ws" "unix:/tmp/nodebb.sock|ws://" not work.

    Best Regards,

  • Installation Errors

    Technical Support
    0 Votes
    1 Posts

    Installing on a KVM VM, Centos 6 64bit. Followed the tutorial

    Getting errors though...

    [root@localhost ~]# curl | bash source ~/.bash_profile % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 101 3442 101 3442 0 0 16694 0 --:--:-- --:--:-- --:--:-- 98342 => Downloading nvm from git to '/root/.nvm' => Initialized empty Git repository in /root/.nvm/.git/ remote: Counting objects: 5491, done. remote: Compressing objects: 100% (7/7), done. Receiving objects: 100% (5491/5491), 1.58 MiB, done. remote: Total 5491 (delta 0), reused 0 (delta 0), pack-reused 5484 Resolving deltas: 100% (3321/3321), done. Note: checking out 'v0.13.1'. You are in 'detached HEAD' state. You can look around, make experimental changes and commit them, and you can discard any commits you make in this state without impacting any branches by performing another checkout. If you want to create a new branch to retain commits you create, you may do so (now or later) by using -b with the checkout command again. Example: git checkout -b new_branch_name HEAD is now at eef12cc... v0.13.1 Deleted branch master (was f9e14b7). => Appending source string to /root/.bash_profile => Close and reopen your terminal to start using nvm [root@localhost ~]# source ~/.bash_profile /usr/bin/which: no node in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/root/bin) [root@localhost ~]# nvm install v0.12.7 # as of this writing check the result of the list-remote to see all choices ######################################################################## 100.0% -bash: manpath: command not found Now using node v0.12.7 [root@localhost ~]# systemctl start redis -bash: systemctl: command not found [root@localhost ~]# [root@localhost ~]# systemctl enable redis -bash: systemctl: command not found'