Error While Upgrading v0.9.4 to v1.0.0: ERR value is not a valid float


  • Swedes

    Is it safe to upgrade to 1.0.0 from 0.9.4 now ?



  • @Jenkler In my case, no not yet. There appears to be an issue with the chats in my forum. I am going to delete them from the database (sorry users) and attempt the upgrade again.

    When I finally do this upgrade to production I will send a mass email to my users letting them know that their chat threads will be deleted and give them a little time to make a copy of them if they care about retaining the content.


  • Swedes

    Ok, good to know

    "I am going to delete them from the database" <-- Can you do that from NodeBB ACP ?



  • @Jenkler Unfortunately I cannot.

    I am using redis and the only plugin I found that manages database entries is for Mongodb. I am going to attempt to load the RedditRedis Desktop Manager. @ThingBreaker



  • @pichalite I've made access to my redis database. I see the "messages" that I should delete. Question about that. Should I delete the entire "message:1", "message:2", etc., entries?
    0_1457114691820_redis_message.png

    Also, it looks like my first attempt to upgrade created four chat rooms. Should I delete them as well or leave them?
    0_1457114710420_redis_chat.png

    Thank you.


  • Plugin & Theme Dev

    @rod not sure. you can probably delete them if you don't need those back



  • After deleting the "message:x" database keys the upgrade completed without error.

    Upon startup though I am getting an error that is keeping NodeBB from starting:

    $ ./nodebb log
    
    Type Ctrl-C to exit
    
    
    NodeBB v1.0.0 Copyright (C) 2013-2014 NodeBB Inc.
    This program comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    
    Clustering enabled: Spinning up 1 process(es).
    
    4/3 14:13 [17972] - info: Time: Fri Mar 04 2016 14:13:43 GMT-0700 (MST)
    4/3 14:13 [17972] - info: Initializing NodeBB v1.0.0
    [outdated] nodebb-plugin-soundpack-default installed v0.1.5, package.json requires 0.1.6
    4/3 14:13 [17972] - warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:
    4/3 14:13 [17972] - warn:     ./nodebb upgrade
    [cluster] Child Process (17972) has exited (code: 0, signal: null)
    

    I ran the upgrade again but still end up with this error upon starting. I do not recall installing the nodebb-plugin-soundpack-default plugin. I believe it is native to NodeBB.

    Help please on what to look at next.

    Thank you.


  • Plugin & Theme Dev

    @rod that's an issue reported here https://github.com/NodeBB/NodeBB/issues/4310

    pull latest v1.x.x and try upgrade again

    ghost created this issue in NodeBB/NodeBB

    closed v1.x.x outdated shrinkwrap #4310



  • @pichalite I did a git pull and now have a hash of 55b43dca23702dca935aabb953594c8a343ee259

    Ran the upgrade successfully.

    Started NodeBB but had an imgbed plugin errror. I ran the ./nodebb reset -p nodebb-plugin-imgbed command and then attempted the startup. NodeBB started up this time!

    I have upgraded all of my plugins that had available upgrades including the imgbed one. Now on startup it doesn't throw an error. Overall everything is working and I will mark this thread as solved. I won't be upgrading my production to v1.0.0 yet as the Amazon S3 plugin caused NodeBB to crash. I will wait to see if that plugin ever gets updated. @wladiston

    Thank you for your help.



  • Followup. I found a different Amazon S3 uploader plugin that seems to be working under v1.0.0. If interested see here


Log in to reply
 

Suggested Topics

| |