Error: Invalid format: 0



  • I was attemping to upload a file for my profile picture (in my profile page)
    and I had a fatal error throw:

    26/2 13:41 [5564] - error: Error: Invalid format: 0
        at getBytesPerComponent (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:38:10)
        at readExifTag (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:45:23)
        at readIFDSection (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:88:9)
        at Object.module.exports.parseTags (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:130:3)
        at C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\parser.js:143:29
        at Object.module.exports.parseSections (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\jpeg.js:21:4)
        at Object.Parser.parse (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\parser.js:140:8)
        at exifRotate (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:269:42)
        at Jimp.parseBitmap (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:250:13)
        at C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:169:29
        at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:380:3)
    Error: Invalid format: 0
        at getBytesPerComponent (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:38:10)
        at readExifTag (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:45:23)
        at readIFDSection (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:88:9)
        at Object.module.exports.parseTags (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\exif.js:130:3)
        at C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\parser.js:143:29
        at Object.module.exports.parseSections (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\jpeg.js:21:4)
        at Object.Parser.parse (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\node_modules\exif-parser\lib\parser.js:140:8)
        at exifRotate (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:269:42)
        at Jimp.parseBitmap (C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:250:13)
        at C:\Users\Jacob\Desktop\Forum\node_modules\jimp\index.js:169:29
        at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:380:3)
    26/2 13:41 [5564] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    26/2 13:41 [5564] - info: [app] Database connection closed.
    26/2 13:41 [5564] - info: [app] Web server closed to connections.
    26/2 13:41 [5564] - info: [app] Shutdown complete.
    

    NOTE, this was after running git pull for the latest fix on uploading default profile pictures.


  • Admin

    git rev-parse HEAD please 😄



  • 5f3473142e017918c32286466187e73ceefe0d7e


  • Admin

    Eh, what kind of file are you uploading?


  • Plugin & Theme Dev

    never mind... I was looking at wrong hash



  • I'm uploading a .png, or well... trying to haha.



  • What is the exact name of the file, size in pixels and size in KB?

    Cannot reproduce here on community forum.



  • Seems to be doing it for every file I try. I'll export my data and re-install.



  • There are no issues reported in exif-parser module repo.
    https://github.com/bwindels/exif-parser

    And no issues like this reported for jimp.
    https://github.com/oliver-moran/jimp



  • Could you please test it on NodeBB 1.0.0?

    Similar issue:
    https://community.nodebb.org/topic/8053/nodebb-1-0-0-load-avatar-error-502/3


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.