0.7.3 -> 0.9.x



  • Hello there! Haven't update since summer, trying to do it now :)

    1. Should i update to 0.8.x first and then to 0.9.x? Or i can miss 0.8.x step?
    2. I have compilation error during ./nodebb upgrade (on every branch - 0.8.x, 0.9.x, master)
      http://pastebin.com/aZtfwJSL
      I've tried with both 4/5 NodeJS

  • GNU/Linux

    According to the docs, it is not recommended to jump from 0.7.x to 0.9.x. Best practice at the moment would be to upgrade to the last version of 0.7.x branch, then proceed to 0.8.x and from there move on to 0.9.x.

    More info here: https://docs.nodebb.org/en/latest/upgrading/index.html#upgrade-path



  • Ok, but anyway i have compilation problem



  • How does nodebb depends on 'lwip' module? I haven't find it in direct dependencies... Can we somehow avoid using it? All my problems because of it :(



  • I had a few issues upgrading from 0.6 to 0.9.
    Manually running npm install and then run the nodebb install command usually sorted everything out for me.


  • Plugin & Theme Dev

    @APXEOLOG I believe lwip module was removed from NodeBB v0.9.x. You can try the upgrade from 0.7 to 0.8 by removing the lwip module from package.json after fetching v0.8.x code from git and before running ./nodebb upgrade


  • Admin

    @APXEOLOG NodeBB doesn't depend on lwip any longer, but it did for the v0.8.x branch, so you will need to install it in order to pass the startup checks so the upgrade can take place.



  • Yep, 0.9.x don't crash after i removed lwip, but i can't upgrade, because i cannot update db to 0.8 version (because of lwip). Can i somehow skip every stages except db update for 0.8.x upgrade?


  • Admin

    Possibly. Try this.

    In src/meta/dependencies.js, change the beginning of the function definition for Meta.dependencies.check like so:

    Meta.dependencies.check = function(callback) {
        return callback();
        // ... rest of method
    

Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.