Error after update to 0.9.3


  • GNU/Linux

    
    root@server:~/nodebb_es# ./nodebb upgrade
    1. Bringing base dependencies up to date... OK
    2. Updating NodeBB data store schema.
    Warning: Redis server does not require a password, but a password was supplied.
    Warning: Redis server does not require a password, but a password was supplied.
    Warning: Redis server does not require a password, but a password was supplied.
    21/12 19:29 [25092] - info: Beginning database schema update
    21/12 19:29 [25092] - info: [2015/09/30] Converting default Gravatar image to default User Avatar skipped
    21/12 19:29 [25092] - info: [2015/11/06] Gravatar removal skipped
    21/12 19:29 [25092] - info: [upgrade] Schema already up to date!
    OK
    
                                                            NodeBB Upgrade Complete!
    
    
    root@server:~/nodebb_es# ./nodebb start
    
    Starting NodeBB
      "./nodebb stop" to stop the NodeBB server
      "./nodebb log" to view server output
      "./nodebb restart" to restart NodeBB
    
    
    

    But when i acces my web i get :

    502 Bad Gateway
    nginx/1.4.6 (Ubuntu)
    

    On logs i see this :

    root@server:~/nodebb_es# ./nodebb log
    
    Type Ctrl-C to exit
    
        at listen (net.js:1065:10)
        at Server.listen (net.js:1139:5)
        at listen (/root/nodebb_es/src/webserver.js:180:17)
        at /root/nodebb_es/src/webserver.js:57:3
        at EventEmitter.<anonymous> (/root/nodebb_es/src/emitter.js:17:5)
        at EventEmitter.emit (events.js:92:17)
        at /root/nodebb_es/src/meta/js.js:217:12
        at /root/nodebb_es/node_modules/nodebb-plugin-ns-awards/node_modules/fs-extra/node_modules/graceful-fs/graceful-fs.js:42:10
    21/12 19:30 [25110] - error: NodeBB address in use, exiting...
    [cluster] Child Process (25110) has exited (code: 0, signal: null)
    
    

    No db backup maded ...i know , epic fail . 😞


  • Admin

    Run ./nodebb dev to run NodeBB without daemonizing.

    Ctrl-C to exit.


  • GNU/Linux

    @julian said:

    Run ./nodebb dev to run NodeBB without daemonizing.

    Ctrl-C to exit.

    21/12 20:31 [730] - error: Error: listen EADDRINUSE
    at errnoException (net.js:905:11)
    at Server._listen2 (net.js:1043:14)
    at listen (net.js:1065:10)
    at Server.listen (net.js:1139:5)
    at listen (/root/nodebb_es/src/webserver.js:180:17)
    at /root/nodebb_es/src/webserver.js:57:3
    at EventEmitter.<anonymous> (/root/nodebb_es/src/emitter.js:17:5)
    at EventEmitter.emit (events.js:92:17)
    at /root/nodebb_es/src/meta/css.js💯14
    at /root/nodebb_es/node_modules/async/lib/async.js:721:13
    21/12 20:31 [730] - error: NodeBB address in use, exiting...
    [cluster] Child Process (730) has exited (code: 0, signal: null)

    Then i start nodebb forum...but is not starting ..

    NodeBB could not be restarted, as a running instance could not be found.


  • GNU/Linux

    @julian

    What else can i do ? 😞


  • Plugin & Theme Dev

    @djcyry not sure if there is a different solution but try rebooting the machine...


  • GNU/Linux

    @pichalite said:

    @djcyry not sure if there is a different solution but try rebooting the machine...

    I have rebooted , not results...


  • Plugin & Theme Dev

    @djcyry I was only referring to this issue.... "EADDRINUSE"


  • GNU/Linux

    @pichalite said:

    @djcyry I was only referring to this issue.... "EADDRINUSE"

    Yes , and i get the same error , i dont know why .

    21/12 21:40 [742] - info: Enabling 'trust proxy'
    21/12 21:40 [742] - error: Error: listen EADDRINUSE
    at errnoException (net.js:905:11)
    at Server._listen2 (net.js:1043:14)
    at listen (net.js:1065:10)
    at Server.listen (net.js:1139:5)
    at listen (/root/nodebb_es/src/webserver.js:180:17)
    at /root/nodebb_es/src/webserver.js:57:3
    at EventEmitter.<anonymous> (/root/nodebb_es/src/emitter.js:17:5)
    at EventEmitter.emit (events.js:92:17)
    at /root/nodebb_es/src/meta/css.js💯14
    at /root/nodebb_es/node_modules/async/lib/async.js:721:13
    21/12 21:40 [742] - error: NodeBB address in use, exiting...
    [cluster] Child Process (742) has exited (code: 0, signal: null)


  • Plugin & Theme Dev

    @djcyry what do you get when you run this?

    netstat -tulpn


  • GNU/Linux

    @pichalite said:

    @djcyry what do you get when you run this?

    netstat -tulpn

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 420/sshd
    tcp 0 0 0.0.0.0:4567 0.0.0.0:* LISTEN 690/nodejs
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 556/master
    tcp 0 0 127.0.0.1:6379 0.0.0.0:* LISTEN 576/redis-server 12
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 456/nginx
    tcp6 0 0 :::80 :::* LISTEN 456/nginx


  • Plugin & Theme Dev

    @djcyry did you setup any script to automatically start NodeBB on system startup?


  • GNU/Linux

    @pichalite said:

    @djcyry did you setup any script to automatically start NodeBB on system startup?

    No , only i made the update to 0.9.3...and boom , error .


  • Plugin & Theme Dev

    @djcyry so..... did you really reboot your machine when I asked you to try?


  • GNU/Linux

    @pichalite said:

    @djcyry so..... did you really reboot your machine when I asked you to try?

    Yes , i rebooted it 3-4 times in the last hour , and run again ./nodebb dev .


  • Plugin & Theme Dev

    @djcyry can you paste the contents of your config.json?


  • GNU/Linux

    @pichalite said:

    @djcyry can you paste the contents of your config.json?

    {
    "url": "http://www.nodebb.es",
    "secret": "86df865a-c4a2-4060-be42-be1cdbfddddddddd",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "pass",
    "database": "1"
    }
    }


  • Plugin & Theme Dev

    @djcyry well that's the problem... you don't have a port specified in your config.json

    You already have hercio.net running on port 4567. Running NodeBB without a port setting in config.json will try to run it on 4567 and it's already being used in your case.

    Add this to your config.json

    "port": "4568"


  • GNU/Linux

    @pichalite said:

    @djcyry well that's the problem... you don't have a port specified in your config.json

    You already have hercio.net running on port 4567. Running NodeBB without a port setting in config.json will try to run it on 4567 and it's already being used in your case.

    Add this to your config.json

    "port": "4568"

    /root/nodebb_es/node_modules/nconf/lib/nconf/stores/file.js:153
    throw new Error("Error parsing your configuration file: [" + this.file + '
    ^
    Error: Error parsing your configuration file: [/root/nodebb_es/config.json]: Unexpected string
    at File.loadSync (/root/nodebb_es/node_modules/nconf/lib/nconf/stores/file.js:153:11)
    at Provider.add (/root/nodebb_es/node_modules/nconf/lib/nconf/provider.js:137:23)
    at Provider.file (/root/nodebb_es/node_modules/nconf/lib/nconf/provider.js:63:15)
    at Object.<anonymous> (/root/nodebb_es/loader.js:14:20)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)


  • Plugin & Theme Dev

    @djcyry what does your new config.json look like?


  • GNU/Linux

    @pichalite said:

    @djcyry what does your new config.json look like?

    {
    "url": "http://www.nodebb.es",
    "port": "4568"
    "secret": "86df865a-c4a2-4060-be42-be1cdbf1b3cd",
    "database": "redis",
    "redis": {
    "host": "127.0.0.1",
    "port": "6379",
    "password": "pass",
    "database": "1"
    }

    }


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.