Upgrade to v0.9.1 breaks my installation

Technical Support
  • Hey guys,
    I upgraded to v0.9.1 and thought that everything went fine, quickly wrote an announcment for my users and then went to bed. Today I am confronted with multiple responses to my announcment stating that essential functionality of the forum is broken.

    • Pressing the reply button does not open a text field but only shows a small red plus button in the bottom right corner. Clicking this button twice or pressing the reply button again then takes my to the response text field.
    • Editing a posting is not possible at all. The red button is shown but no matter how often I click it or the edit menu entry, nothing happens.
    • After one response is made, the reply button stops working, too. I have to completely reload the browser to be able to reply again..
    • Same holds for chats windows. After any action I made on the page I cannot open chat windows.

    I tried ./nodebb reset -p which restored almost all functionality. I am now able to reply and edit as expected with just nodebb-plugin-composer-default activated.
    However, when toggling between the half- and the fullsize response field the page will (after a small number of times where it works as expected) only show the fullsize variant. No matter what I try (reloading the page, logging in and out, even restarting the whole forum) I cannot bring the halfsize variant back.

    I then tried ./nodebb reset -a which failed with the following error message:

    $ ./nodebb reset -a
    8/12 16:26 [25051] - info: [database] Checking database indices.
        process.nextTick(function() { throw err; });
    Error: Cannot find module './src/widgets'
        at Function.Module._resolveFilename (module.js:338:15)
        at Function.Module._load (module.js:280:25)
        at Module.require (module.js:364:17)
        at require (module.js:380:17)
        at resetWidgets /path/to/nodebb/src/reset.js:107:2)
        at iterate /path/to/nodebb/node_modules/async/lib/async.js:262:13)
        at async.forEachOfSeries.async.eachOfSeries (/path/to/nodebb/node_modules/async/lib/async.js:281:9)
        at _parallel /path/to/nodebb/node_modules/async/lib/async.js:712:9)
        at Object.async.series (/path/to/nodebb/node_modules/async/lib/async.js:734:9)

    Can anyone help me to bring my forum back to a working state?
    How could I quickly restore the forum to an older version so that I can get it back online for my community?

    Edit: By activating all plugins one after another I found that all that reply / edit problems probably come from a custom plugin that we used for text replacement in postings. Which essentially leaves the error message from above as well as the fullsize response window as the only problems I am facing right now.

  • I think ./nodebb reset -a has been broken for some time now, so it's not a big issue (just do -t or -p as required).

    As for the composer, have you tried clicking and dragging to resize?

  • Thanks @julian for pointing out something that seems to be quite obvious, yet I did not try to do that before :).
    Honestly, I didn't even know that dragging the composer is possible.
    I have absolutely no idea why it got resized automatically in the first place, even across multiple browsers that I tried, but it seems to work now. I'll report back in case the resizing happens again.

  • Funny story about that, the initial behaviour was click-drag. Clicking the button did absolutely nothing.

    Someone then made a pull request to maximize on click, and it seems to be the default behaviour for some people now 😆

  • @julian speaking of the composer, I think the button with the "+" icon is used for the wrong purpose here. I think any button with a "+" sign denotes you are either creating or adding something. All the button here does is hide and show the composer. The icon needs to be changed.

  • Are you referring to the taskbar icon when a new topic composer is open?

    I agree, it ought to be a different icon.

  • @julian Yes the taskbar Icon

Suggested Topics