Upgrade worked but can't start nodebb anymore

Technical Support
  • Hi guys, i upgraded from v0.8.2 to v0.9.0 everything worked great but then when i start nodebb with ./nodebb start nothing happen so i do a ./nodebb status to see if it's running and it doesn't so i do a ./nodebb log to see the problem and it says:
    12/11 10:01 [32692] - info: Time: Thu Nov 12 2015 10:01:14 GMT+0100 (CET)
    12/11 10:01 [32692] - info: Initializing NodeBB v0.9.0
    12/11 10:01 [32692] - error: Unable to initialize Redis! Is Redis installed? Error :Cannot find module 'redis'
    [cluster] Child Process (32692) has exited (code: 0, signal: null)
    which doesn't make sense because when i do service redis-server status it says it's running and it doesn't has error, so how come nodebb doesn't want to start ?
    Thanks in advance

  • Go to your config.json under /nodebb/config.json check that the host is correct (usually and port (usually 6379) and password (default is "") i dont recommend not having a password.

    also try to restart your redis server.

    Another way also is to type: redis-cli on your terminal and see if that connects you to your local redis server

  • @geobz said:


    it is
    "database": "redis",
    "redis": {
    "host": "",
    "port": "6379",
    "password": "",
    "database": "0"

    and when i do edis-cli it does connect

  • npm i redis --save

  • Also had that, whats your NodeJS version?

  • @mega Don't forget connect-redis 🙂

    npm i redis@~0.10.1 connect-redis@~2.0.0

Suggested Topics