Problems sendind Emails, trying with Mandrill, local and local-SSL


  • Anime Lovers

    Hello, I'm not sure really whats going on, a couple days ago the forum was sending out emails through Mandrill with no problems but for some reason now its not interacting with the service and now I'm trying with a different SMTP using the local and local-SSL plugins but also nothing happens... I have tried to check the Advanced>Logs but nothing shows up at all the last output shows "24/9 11:11 [4208] - info: NodeBB is now listening on: 0.0.0.0:4567" but it doesn't update anything else, if it helps to know I update the NodeBB project almost daily based on the NodeBB Git so I should have the most recent changes... which could be the reason for it not to work now...

    Extra information:

    • "You are running NodeBB v0.8.2."
    • "Emailer Installed"
    • "it says Email sent when I use the SEND TEST EMAIL option"

    I'm baffled ... if anyone has any ideas or you need more information please let me know so I can provide it.

    Thanks for the help!


  • Translator

    Hhmmm, in your Mandrill control panel do you see the emails being send out or isn't it sending them at all?


  • Anime Lovers

    No, it just shows the activity from 2 days ago.

    mandrill.png

    I'm testing things here, and I went back to a pull made 3 days ago by baris "Merge pull request #3636 from HorusGoul/HorusGoul" and now is sending emails again... seems that something was updated recently and broke the emails or something...



  • Try Mailgun once please.


  • Anime Lovers

    Well, I went back to a pull from 3 days ago, tried with Mailgun and it worked.... then reset the NodeBB folder to the latest pull from Git... and again it doesn't do anything (The one that works is where in the ACP has no options to changes templates, now with the templates it just doesn't work).


  • Translator

    What branch are you pulling from and what is your hash? This change is on master now i believe (Feel free to correct me if i'm wrong):

    @baris said:

    Hook changes

    Filter

    • action:email.send and filter:email.send renamed see this commit

    0.9.0 Breaking Changes

    You can pull them from github, but don't get them via ./nodebb upgrade


  • Anime Lovers

    Oh boy, I have to admit that I'm very new to using GitHub, all I did was to install Git on the pc (Windows) then used Git Extensions to clone the project for NodeBB to a local folder, and then I setup that folder with the npm install, and node app --setup.... so... not sure if that was the correct way to do it... for example the latest commit or push that I see on Git Extensions is the one from Julian "fixes #3669" so by pulling that my NodeBB folder should then be updated to the latest version... isn't it?

    I guess one more thing I don't get is if there is more than one active version of NodeBB cause I see somethings showing v.0.7.x and v.0.8.x, don't know if someone can clarify this to me?

    Thanks.


  • Translator

    @SergioNG said:

    Oh boy, I have to admit that I'm very new to using GitHub, all I did was to install Git on the pc (Windows) then used Git Extensions to clone the project for NodeBB to a local folder, and then I setup that folder with the npm install, and node app --setup.... so... not sure if that was the correct way to do it... for example the latest commit or push that I see on Git Extensions is the one from Julian "fixes #3669" so by pulling that my NodeBB folder should then be updated to the latest version... isn't it?

    Usually it's fine to clone the master of a repo, but the NodeBB team seems to push their version in development to master. (I don't know why.) For that reason you want to clone the latest stable branch, in this case by issuing git clone -b v0.8.x https://github.com/NodeBB/NodeBB.git nodebb

    https://github.com/NodeBB/NodeBB/commit/137f2097db50aa72f530fa3bbab6269b3bb7fcdd

    This is indeed the most recent commit to master (which is in development), and is the most updated one though unstable and not compatible with all plugins.

    @SergioNG said:

    I guess one more thing I don't get is if there is more than one active version of NodeBB cause I see somethings showing v.0.7.x and v.0.8.x, don't know if someone can clarify this to me?

    Thanks.

    Is that in git extensions? If that is the case, you're probably seeing the branhes of different (and old) versions.


  • Anime Lovers

    @atrius Thank you very much for the explanation, for the time being I'll avoid doing it the way I was pulling from Git, right now it's working and sending emails (with the local plugin which is what we actually needed), we'll be more careful when trying to update to the newer stable versions from now on.

    Thank you again.


  • Translator

    You're very welcome @SergioNG, i'm glad i was able to help 😌

    Off-topic: Yay! 3 reputation. No more 10 minute cooldown between posts. Thank you 🐿️




Looks like your connection to NodeBB was lost, please wait while we try to reconnect.