nodebb setup aborted

Feature Requests
  • Hidden --> Information deliberatley taken out

    Welcome to NodeBB!

    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (Hidden)
    Please enter a NodeBB secret (Hidden)
    Which database to use (redis)

    22/8 19:23 [16461] - info: Now configuring redis database:
    Host IP or address of your Redis instance (localhost)
    Host port of your Redis instance (19858) 6379
    Password of your Redis database
    Which database to use (0..n) (0)
    Configuration Saved OK
    [email protected] node_modules/redis

    [email protected] node_modules/connect-redis
    └── [email protected] ([email protected])
    Populating database with default configs, if not already set...
    Previous theme detected, skipping enabling default theme
    Categories OK. Found 4 categories.
    Administrator found, skipping Admin setup
    22/8 19:24 [16461] - warn: NodeBB Setup Aborted.
    Error: ERR wrong number of arguments for 'zadd' command
    at ReplyParser.<anonymous> (/home/tatsumaki/TatsuNodeBB/node_modules/redis/index.js:305:31)
    at ReplyParser.emit (events.js:95:17)
    at ReplyParser.send_error (/home/tatsumaki/TatsuNodeBB/node_modules/redis/lib/parser/javascript.js:296:10)
    at ReplyParser.execute (/home/tatsumaki/TatsuNodeBB/node_modules/redis/lib/parser/javascript.js:181:22)
    at RedisClient.on_data (/home/tatsumaki/TatsuNodeBB/node_modules/redis/index.js:534:27)
    at Socket.<anonymous> (/home/tatsumaki/TatsuNodeBB/node_modules/redis/index.js:91:14)
    at Socket.emit (events.js:95:17)
    at Socket.<anonymous> (stream_readable.js:765:14)
    at Socket.emit (events.js:92:17)
    at emitReadable

    Whats happening here? Followed the digital ocean tut... but it is from 2013. all was well until the very end and then it failed. I had seen something on the forum about redis and nodebb .7 is that this? What am i doing wrong? I even tried redislabs as an external redis server, but still nodebb aborted.

    Jonny Black

  • It looks like your Redis version is out of date, could you run "redis-server --version" and post that here?

  • hey thanks for such a quick reply. 🙂

    the version is 2.2.12. Whats the command to upgrade? I tried using an endpoint address from redislabs to bypass the issue but that ddnt help. 😕


  • Ye, zadd (as described in the error) is a function for redis 3.x.x, since I do not know what is you use I'm going to assume a Debian based one, so this should get you on track

  • Ubuntu 12.04.5 x32 👍

    thanks, hopefully i can nix this error now.

  • soooooo, that worked. 🙂

Suggested Topics

  • 1 Votes
    8 Posts
  • nodebb > phpbb

    Feature Requests
    0 Votes
    2 Posts
  • 2 Votes
    27 Posts
  • 0 Votes
    1 Posts
  • 0 Votes
    25 Posts