NodeBB Plugin-Mentions out of date?



  • I tried updating the nodebb-plugin-mention to v1.0.0. However upon upgrading my entire site crashed.

    The logs said this

    [outdated] nodebb-plugin-mentions v1.0.0, requires ^0.11.7
    

    Is there a way to update my requirements for these plugins? I have a couple other plugins that I haven't been able to upgrade as well


  • Community Rep

    Same thing happened to my site. The requirement is ^0.11.7, which means it wants a version that is equal to or greater than 0.11.7 but less than 1.0.0

    So it considers 1.0.0 too new.

    Either there is a change in 1.0.0 that breaks your version of NodeBB, or they forgot to change the version dependency.

    Just installing the older version should work until they fix it.
    npm i nodebb-plugin-mentions@0.11.7


  • GNU/Linux Admin

    @yariplus said:

    Either there is a change in 1.0.0 that breaks your version of NodeBB

    @SimonQ said:

    However upon upgrading my entire site crashed.

    Yep. It's 1.0.0 because it contains a breaking change that v0.7.2 cannot handle. I know the upgrade button is awfully enticing, but hold off until v0.7.3 is released 😄

    Yes I do also realise that we shouldn't show the upgrade button if the compatibility check fails...



  • Thanks @julian and @yariplus I will hold off from clicking that upgrade button for now. 🙂


Log in to reply
 

Suggested Topics

| |