nodebb.conf is blank

Technical Support

Suggested Topics

  • 0 Votes
    23 Posts

    For my original problem, I think I found a bug.
    For some reason the user password length was set to 0 (I didn't set it that way, it's not possible). When I set up my forum, my password was 7 characters long (before launching the site, I change the password to a complex and unique one, but during the development process I use a simple one that I remember). When I transferred the forum to the server and edited Users -> Settings, I set the minimum password to 8 characters, because it was impossible to leave the field with a default value of 0. And here I see a bug, because no one expects this behavior. Once the minimum password is set, NodeBB simply stops accepting any passwords that are shorter. This is completely non-obvious and as an admin I fell into a trap. I would expect two behaviors:

    Continue to accept set passwords even of shorter length until a password change is required Display a warning and reset passwords of shorter length if the administrator confirms this action.

    Снимок экрана 2023-02-01 в 14.04.48.png

  • 1 Votes
    6 Posts

    @Rektalizer Evidently you have a mish mash of "names" here: - as noted above, this one resolves to IP address -- this one also resolves to IP address -- this one resolves to ... same as before.

    Which are you actually using? If you intend to use more than one of the above then which will be your nodebb forums URL?

    Or is it your intention to have ALL of the above point to your nodebb forums? Note that this can create issues on down the road if, for e.g., you decide to "spin off" www for e.g. a blog or other purposes.

    As for your nginx logs immediately up post, have you adjusted your nginx server_name config to jive with your nodebb config.json yet?

  • 0 Votes
    4 Posts

    @julian said in Search options for 2019 NodeBB:

    Dbsearch is the recommendation

    This is what we are using now. We used to use Solr but it had issues and we came back.

  • 0 Votes
    3 Posts

    Thank you for your answer. I have configured the CORS headers on my reverse proxy (nginx) and it works well now.

    Thank you!

  • 0 Votes
    3 Posts

    @BuZz said in "Recent cards" not working, NodeBB 1.4.5:

    you need to use v 0.3.1 for nodebb v1.4.5
    npm i [email protected] --save

    It is working!