• @baris just about to try this to feed our forum with some RSS.

    Are there any plans on adding RSS content to the 2.x releases, or should I downgrade to have that functionality? Will you continue to support the 1.x releases?

    Thanks!


  • @klockprat answering myself here, I decided to go with an external service instead (Zapier in my case) since I need a couple of other automations as well anyway 🙂

  • NodeBB

    I have no intention to add post parsing to 2.x.


  • @baris suddenly this morning, I am unable to pull any feeds and convert to posts. When checking link URL's, I see

    "getaddrinfo ENOTFOUND query.yahooapis.com"
    

    Along with the below in ./nodebb log

    2021-06-23T10:00:00.181Z [4567/2000] - error: [[nodebb-plugin-rss:error]] Error pulling feed https://www.securitymagazine.com/rss/15 {"0":"g","1":"e","2":"t","3":"a","4":"d","5":"d","6":"r","7":"i","8":"n","9":"f","10":"o","11":" ","12":"E","13":"N","14":"O","15":"T","16":"F","17":"O","18":"U","19":"N","20":"D","21":" ","22":"q","23":"u","24":"e","25":"r","26":"y","27":".","28":"y","29":"a","30":"h","31":"o","32":"o","33":"a","34":"p","35":"i","36":"s","37":".","38":"c","39":"o","40":"m"}
    2021-06-23T10:00:00.234Z [4567/2000] - error: [[nodebb-plugin-rss:error]] Error pulling feed http://feeds.bbci.co.uk/news/technology/rss.xml?edition=uk# {"0":"g","1":"e","2":"t","3":"a","4":"d","5":"d","6":"r","7":"i","8":"n","9":"f","10":"o","11":" ","12":"E","13":"N","14":"O","15":"T","16":"F","17":"O","18":"U","19":"N","20":"D","21":" ","22":"q","23":"u","24":"e","25":"r","26":"y","27":".","28":"y","29":"a","30":"h","31":"o","32":"o","33":"a","34":"p","35":"i","36":"s","37":".","38":"c","39":"o","40":"m"}
    2021-06-23T10:00:00.259Z [4567/2000] - error: [[nodebb-plugin-rss:error]] Error pulling feed https://threatpost.com/category/vulnerabilities/feed {"0":"g","1":"e","2":"t","3":"a","4":"d","5":"d","6":"r","7":"i","8":"n","9":"f","10":"o","11":" ","12":"E","13":"N","14":"O","15":"T","16":"F","17":"O","18":"U","19":"N","20":"D","21":" ","22":"q","23":"u","24":"e","25":"r","26":"y","27":".","28":"y","29":"a","30":"h","31":"o","32":"o","33":"a","34":"p","35":"i","36":"s","37":".","38":"c","39":"o","40":"m"}
    2021-06-23T10:00:00.281Z [4567/2000] - error: [[nodebb-plugin-rss:error]] Error pulling feed https://threatpost.com/category/privacy/feed {"0":"g","1":"e","2":"t","3":"a","4":"d","5":"d","6":"r","7":"i","8":"n","9":"f","10":"o","11":" ","12":"E","13":"N","14":"O","15":"T","16":"F","17":"O","18":"U","19":"N","20":"D","21":" ","22":"q","23":"u","24":"e","25":"r","26":"y","27":".","28":"y","29":"a","30":"h","31":"o","32":"o","33":"a","34":"p","35":"i","36":"s","37":".","38":"c","39":"o","40":"m"}
    
    

    I have an alternative script I developed that uses the NodeBB API to parse URL's and create posts, and this works fine.

    Any thoughts / ideas ? I'm using the last version that includes the feed body and link if that helps ?

    EDIT: According to this, the Yahoo API (both query and weather) were sunset in Jan 2019, but my guess is that they were left on and forgotten, then suddenly, someone decided to actually pull the plug 🙂

    Sadly, if this is correct, it probably means this affects everyone using this extension without refactor of some sort.

  • NodeBB

    @phenomlab Are you using an old version of the plugin? This should be fixed in https://github.com/barisusakli/nodebb-plugin-rss/commit/950dbf392290b38c4b29f458c49fe97caae4949c.

    Plugin no longer uses the yahoo api.


  • @baris Yes, because I need the body populated with the text from the link. If I use the 2.x version, this gets removed.
    Will there be any further updates to the 1.x train ? I have an alternative lined up to meet my needs, but it's a script and not a plugin.

  • NodeBB

    I am looking at 1.x and I don't see it using the yahoo api either https://github.com/barisusakli/nodebb-plugin-rss/blob/1.x/feed.js. What version are you using?


  • @baris 1.2.7


  • @baris I think I might know what caused this. I ran an npm audit fix --force which may have downgraded as I was previously on 1.3.2. Just updated to that, and am testing now.

    EDIT - suspicion confirmed - works fine now 🙂 Sorry for the fire drill.


  • I set it up with a podcast RSS, but instead of posting the description of an item, it posts a link instead in the topic. Is there anyway to change this?

    Edit: Nevermind solved it, installed version 1.3.0

Suggested Topics

| |