Might as well add another cog to my plan im on cent os


  • Why should anything be easy, right? 🙂

    I saw the previous thread re: CentOS and it looked like it was getting nowhere. The wiki link does not work so if anyone has had a head start at all feel free to hit me up. I'm working on a second domain (a clean one to learn on) that I added to the server today. Of course it can never be easy!

    I've installed most everything using sudo/yum/whatever I'm not a server guy so I'm just forcing my way in and hoping I don't blow the whole thing up. Getting close. At the config part for NodeBB I'm getting an error and not making it to the 'pick your admin name' part.. Instead I get an error.

    error:

    events.js:72
    throw er; // Unhandled 'error' event
    ^
    Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED
    at RedisClient.on_error (/home/dadforum/public_html/mynodebb/node_modules/redis/index.js:151:24)
    at Socket.<anonymous> (/home/dadforum/public_html/mynodebb/node_modules/redis/index.js:86:14)
    at Socket.EventEmitter.emit (events.js:95:17)
    at net.js:426:14
    at process._tickCallback (node.js:415:13)

    I'm guessing I forgot to install something along the way which is par for the course with me at times haha.. I'm keeping track of most of what I do to document for others looking at this saying "WANT" but then looking at their various accounts and they're looking back at you saying "CAN'T" ... Much like OJ Simpson, I don't take no for an answer!! 🙂


  • Oh and I followed loosely the instructions that are on the wiki.. So I put in the IP and then hit enter key for all other questions. Maybe Redis is not connecting or I missed a step and jacked that part of the install up?

    Either way it's break time right now.. Bathtime for the kid and putting her to sleep soon I'll be back at my desk around 11pm to try to break this sucker some more 🙂

  • GNU/Linux Admin

    Great start! Did you install Redis?

    sudo yum install redis-server

  • Now I am... 🙂 then back to child rearing but I couldn't reply on iPad it kept telling me I'm already a user when trying to login with Twitter on a second device


  • Great start! Did you install Redis?

    sudo yum install redis-server
    

    No package redis-server available.

    Maybe try from root instead of the individual account?


  • jesus I'm a danger to my own self with this stuff... i figured out how to list packages (keep in mind i'm free balling this entire process I have .000000001% of the server knowledge of anyone else in here if that) ... and it looks like no redis listed..

  • GNU/Linux Admin

    Eep, looks like you may have to install it manually!! :S

    http://thoughts.z-dev.org/2013/05/27/install-redis-on-centos-6-4/


  • Eep, looks like you may have to install it manually!! :S

    http://thoughts.z-dev.org/2013/05/27/install-redis-on-centos-6-4/

    A+ appreciate the help going back to the office in 30 min.. I had to install node manually too starting to get the hang of this all..


  • I also had to install some of he line item ones like imagemagick separately before it didn't like them batched for whatever reason... Live and learn. At least the centOS wiki can link to something soon to make more people dangerous 🙂

  • GNU/Linux Admin

    I also had to install some of he line item ones like imagemagick separately before it didn't like them batched for whatever reason... Live and learn. At least the centOS wiki can link to something soon to make more people dangerous 🙂

    If you'd like to try the "easy mode", give Ubuntu a try... I reckon it's more user friendly than CentOS!


  • I also had to install some of he line item ones like imagemagick separately before it didn't like them batched for whatever reason... Live and learn. At least the centOS wiki can link to something soon to make more people dangerous 🙂

    If you'd like to try the "easy mode", give Ubuntu a try... I reckon it's more user friendly than CentOS!

    Yep I finally managed it on Ununtu as long as you are in the correct directory it should be ok.


  • I also had to install some of he line item ones like imagemagick separately before it didn't like them batched for whatever reason... Live and learn. At least the centOS wiki can link to something soon to make more people dangerous 🙂

    If you'd like to try the "easy mode", give Ubuntu a try... I reckon it's more user friendly than CentOS!

    Yeah but I'm using the existing server we pay for on the auto forums.. I have no idea how to get another OS setup on the server that's a leap year away.. Fell asleep last night I'm going to give it a shot now and see what happens 🙂


  • I AM ACTIVE!!!!

    Now I just have to get it to work on the actual www.domain.com instead of the IP based since nobody is going to hand out cards saying "check out my website at IP Address: 69.69.69.222:3456"

    Baby steps! I knew taking a break was the smartest thing last night.


  • Congrats @outlawedoffroad just in case you missed it you need to install & run Forever Daemon to keep the forum running when you shut down your terminal.
    https://github.com/designcreateplay/NodeBB/wiki/How-to-run-NodeBB


  • Congrats @outlawedoffroad just in case you missed it you need to install & run Forever Daemon to keep the forum running when you shut down your terminal.
    https://github.com/designcreateplay/NodeBB/wiki/How-to-run-NodeBB

    I'm screwing around with that now 🙂

    Still trying to figure out how to have the url load the ip it must be something in .htaccess a redirect or whatever to get going..

    No idea how I got this far lol but I'm happy I did.. This is only just the beginning though.


  • Forever now working.. I don't want to reboot server yet cause the 2 car forums on vb have their morning rush of people sitting in work talking about going fast or over things 🙂

    So now I am going to focus on getting the URL to show the forum instead of only the IP.. Google search Mode Activate!


  • you will need to go to the domain registrar for your domain and change the A records to the new i.p for the url if that makes sense 🙂


  • you will need to go to the domain registrar for your domain and change the A records to the new i.p for the url if that makes sense 🙂

    yeah i was thinking that's going to be the deal.. i forward from the place i buy them to my server with my own name server so next step is to edit that in whm somewhere... i'm shocked the other 2 sites did not belly up from all this stuff never a good feeling hitting command line things you only kinda/sorta know what it'll do


  • Grrr it's not allowing me to put in ports, defeating the purpose of trying to edit it here!! Calgon take me awwwaaaayyyyy!!!!!!


  • Chat room line to get help from the host.. They're great and will straighten it out in seconds compared to my searching and jerking for hours.. I guess this will also be good for LiquidWeb as a host for self-installers once all these little details are ironed out.

Suggested Topics

  • 8
  • 7
  • 3
  • 3
  • 11
| |